summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commit171699a002ecd434bf376ad233dbe24d18eb2eb6 (patch)
tree6f899a3828a1e37ab8065f27a01b95c12cdc03e0 /kde-base/okular
parentbump to the TeX Live 2011 version (diff)
downloadhistorical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.gz
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.tar.bz2
historical-171699a002ecd434bf376ad233dbe24d18eb2eb6.zip
[kde-base] Version bump KDE SC 4.7.0
Package-Manager: portage-2.2.0_alpha47/cvs/Linux x86_64
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.7.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index ee30ae8f3bf2..970fb15d4edc 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.106 2011/07/09 15:14:18 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.107 2011/07/27 14:04:27 alexxy Exp $
+
+*okular-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*okular-4.6.5 (09 Jul 2011)
diff --git a/kde-base/okular/okular-4.7.0.ebuild b/kde-base/okular/okular-4.7.0.ebuild
new file mode 100644
index 000000000000..c33fbd5ae2e2
--- /dev/null
+++ b/kde-base/okular/okular-4.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.7.0.ebuild,v 1.1 2011/07/27 14:04:27 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.12.3-r3[lcms,qt4,-exceptions] )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}