summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
commit2949ed61ac331b42c84eab992aba8a8aa245811c (patch)
treeb8dc20afdeb0bb71b28d488e020b2d45cf5f25a6 /kde-base/phonon-kde
parentRemoving 0.1.0 ebuild (diff)
downloadhistorical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.gz
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.bz2
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.zip
Version bump KDE 4.3.3
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.3.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 9ba5dc767c67..623818b59b5b 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.27 2009/10/18 17:46:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.28 2009/11/02 22:07:45 wired Exp $
+
+*phonon-kde-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +phonon-kde-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> phonon-kde-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/phonon-kde/phonon-kde-4.3.3.ebuild b/kde-base/phonon-kde/phonon-kde-4.3.3.ebuild
new file mode 100644
index 000000000000..236f9a64fec1
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.3.3.ebuild,v 1.1 2009/11/02 22:07:45 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="debug pulseaudio +xine"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-sound/phonon[xine?]
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker phonon-xine
+
+src_prepare() {
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ # Disable automagic
+ sed -e 's/find_package(Xine)/macro_optional_find_package(Xine)/' \
+ -i phonon/kcm/xine/CMakeLists.txt || die "Failed to make xine optional"
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ $(cmake-utils_use_with xine)"
+
+ kde4-meta_src_configure
+}