summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-17 13:29:14 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-17 13:29:14 +0000
commit8991299fceae45711acfd1dd86e7bb731cc0b359 (patch)
tree1189cc3c3701ffc30ab86915519662be0366567a /kde-base/qtruby
parentStable on alpha, bug #383991 (diff)
downloadhistorical-8991299fceae45711acfd1dd86e7bb731cc0b359.tar.gz
historical-8991299fceae45711acfd1dd86e7bb731cc0b359.tar.bz2
historical-8991299fceae45711acfd1dd86e7bb731cc0b359.zip
Remove KDE SC 4.7.3.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.7.3.ebuild75
2 files changed, 4 insertions, 76 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index cf32bbc6c932..9518797130c7 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.97 2012/01/16 23:48:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.98 2012/01/17 13:28:57 johu Exp $
+
+ 17 Jan 2012; Johannes Huber <johu@gentoo.org> -qtruby-4.7.3.ebuild:
+ Remove KDE SC 4.7.3
16 Jan 2012; Agostino Sarubbo <ago@gentoo.org> qtruby-4.7.4.ebuild:
Stable for amd64, wrt bug #396359
diff --git a/kde-base/qtruby/qtruby-4.7.3.ebuild b/kde-base/qtruby/qtruby-4.7.3.ebuild
deleted file mode 100644
index 5e75d1d2d6f6..000000000000
--- a/kde-base/qtruby/qtruby-4.7.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.7.3.ebuild,v 1.3 2011/12/07 22:13:46 hwoarang Exp $
-
-EAPI=4
-
-OPENGL_REQUIRED="always"
-DECLARATIVE_REQUIRED="optional"
-KDE_REQUIRED="never"
-KDE_SCM="git"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="Qt Ruby bindings"
-KEYWORDS="amd64 x86"
-IUSE="debug phonon qscintilla qwt webkit"
-
-DEPEND="
- $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
-"
-
-RDEPEND="${DEPEND}
-"
-
-# Split from kdebindings-ruby in 4.7
-add_blocker kdebindings-ruby
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- local CMAKE_USE_DIR=${S}
- mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_disable declarative QtDeclarative)
- $(cmake-utils_use_with phonon)
- $(cmake-utils_use_with qscintilla QScintilla)
- $(cmake-utils_use_with qwt Qwt5)
- $(cmake-utils_use_disable webkit QtWebKit)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- local CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}