summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit4816953d7b880b98d593a026f8417178af0c61d9 (patch)
treef2e62f96dd734dff956565c230831b7cc368b4f5 /kde-base/smoke
parentVersion bump. Remove intermediate version. (diff)
downloadhistorical-4816953d7b880b98d593a026f8417178af0c61d9.tar.gz
historical-4816953d7b880b98d593a026f8417178af0c61d9.tar.bz2
historical-4816953d7b880b98d593a026f8417178af0c61d9.zip
Version bump to KDE SC 4.6.3.
Package-Manager: portage-2.2.0_alpha31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.6.3.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 513938e4921a..96007a646f1e 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.128 2011/04/17 12:25:32 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.129 2011/05/07 10:47:55 scarabeus Exp $
+
+*smoke-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> +smoke-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
17 Apr 2011; Thomas Kahle <tomka@gentoo.org> smoke-4.4.5-r1.ebuild:
x86 stable per bug 354569
diff --git a/kde-base/smoke/smoke-4.6.3.ebuild b/kde-base/smoke/smoke-4.6.3.ebuild
new file mode 100644
index 000000000000..d484171ef422
--- /dev/null
+++ b/kde-base/smoke/smoke-4.6.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.6.3.ebuild,v 1.1 2011/05/07 10:47:55 scarabeus Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ eclass=kde4-base
+else
+ KMNAME="kdebindings"
+ eclass=kde4-meta
+fi
+
+inherit ${eclass}
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="akonadi attica debug kate okular +phonon qimageblitz qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ kate? ( $(add_kdebase_dep kate) )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+KMSAVELIBS=1
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ ${eclass}_src_configure
+}