summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 23:49:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 23:49:11 +0000
commitff731086c9206d2af2c19afd8b89812734100960 (patch)
treee22ca61756c439eeb4326cfe1f8d3a06db92753e /kde-base
parentdev-lisp/abcl:cmucl - Build Armed Bear Common Lisp using CMU Common Lisp (diff)
downloadhistorical-ff731086c9206d2af2c19afd8b89812734100960.tar.gz
historical-ff731086c9206d2af2c19afd8b89812734100960.tar.bz2
historical-ff731086c9206d2af2c19afd8b89812734100960.zip
Added patch to disable xinerama support from ksplashml.
Package-Manager: portage-2529-svn
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/ChangeLog6
-rw-r--r--kde-base/kdebase/files/ksplashml-3.5.0-xinerama.patch32
-rw-r--r--kde-base/kdebase/kdebase-3.5.0-r1.ebuild20
-rw-r--r--kde-base/ksplashml/ChangeLog8
-rw-r--r--kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch32
-rw-r--r--kde-base/ksplashml/ksplashml-3.5.0.ebuild19
6 files changed, 101 insertions, 16 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 439e35ec3223..cfe31891f67c 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.251 2006/01/11 20:26:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.252 2006/01/11 23:47:43 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/ksplashml-3.5.0-xinerama.patch, kdebase-3.5.0-r1.ebuild:
+ Added patch to disable xinerama support from ksplashml.
11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/kicker-3.5.0-composite.patch, kdebase-3.5.0-r1.ebuild:
diff --git a/kde-base/kdebase/files/ksplashml-3.5.0-xinerama.patch b/kde-base/kdebase/files/ksplashml-3.5.0-xinerama.patch
new file mode 100644
index 000000000000..4b824247e89b
--- /dev/null
+++ b/kde-base/kdebase/files/ksplashml-3.5.0-xinerama.patch
@@ -0,0 +1,32 @@
+Index: kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in
+===================================================================
+--- kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (revision 497108)
++++ kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (working copy)
+@@ -1,9 +1,13 @@
+-xinerama_save_ldflags="$LDFLAGS"
+-LDFLAGS="$X_LDFLAGS"
+-
+ LIB_XINERAMA=
+
+-KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
++AC_ARG_WITH([xinerama],
++ AS_HELP_STRING([--without-xinerama], [Disable xinerama extension support (default: check)]) )
++
++if test "x$with_xinerama" != "xno"; then
++ xinerama_save_ldflags="$LDFLAGS"
++ LDFLAGS="$X_LDFLAGS"
++
++ KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
+ [
+ AC_CHECK_LIB(Xinerama,XineramaQueryExtension,
+ [
+@@ -17,5 +21,7 @@
+ #include <X11/Xlib.h>
+ ] )
+
+-AC_SUBST(LIB_XINERAMA)
+-LDFLAGS="$xinerama_save_ldflags"
++ AC_SUBST(LIB_XINERAMA)
++ LDFLAGS="$xinerama_save_ldflags"
++fi
++
diff --git a/kde-base/kdebase/kdebase-3.5.0-r1.ebuild b/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
index ea779e9f7c26..12d6f954f574 100644
--- a/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
+++ b/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0-r1.ebuild,v 1.11 2006/01/11 20:26:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0-r1.ebuild,v 1.12 2006/01/11 23:47:43 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -8,7 +8,7 @@ DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror...
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="arts cups java ldap ieee1394 hal lm_sensors logitech-mouse openexr opengl
-pam samba ssl zeroconf xcomposite xscreensaver"
+pam samba ssl zeroconf xcomposite xscreensaver xinerama"
# hal: enables hal backend for 'media:' ioslave
DEPEND="arts? ( ~kde-base/arts-${PV} )
@@ -43,10 +43,8 @@ RDEPEND="${DEPEND}
x11-libs/libXdamage
) <=x11-base/xorg-x11-6.9 )
)
- xscreensaver? ( || ( (
- x11-libs/libXScrnSaver
- ) virtual/x11 )
- )"
+ xscreensaver? ( || ( x11-libs/libXScrnSaver virtual/x11 ) )
+ xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )"
DEPEND="${DEPEND}
xcomposite? ( || ( (
@@ -54,10 +52,8 @@ DEPEND="${DEPEND}
x11-proto/damageproto
) <=x11-base/xorg-x11-6.9 )
)
- xscreensaver? ( || ( (
- x11-proto/scrnsaverproto
- ) virtual/x11 )
- )
+ xscreensaver? ( || ( x11-proto/scrnsaverproto virtual/x11 ) )
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )
dev-util/pkgconfig"
src_unpack() {
@@ -93,6 +89,9 @@ src_unpack() {
# kwin patch.
epatch "${FILESDIR}/kicker-3.5.0-composite.patch"
+ # Add --without-xinerama option to disable xinerama on ksplashml
+ epatch "${FILESDIR}/ksplashml-3.5.0-xinerama.patch"
+
# For the noimake patch.
make -f admin/Makefile.common || die
}
@@ -107,6 +106,7 @@ src_compile() {
$(use_enable zeroconf dnssd)
$(use_with xcomposite composite)
$(use_with xscreensaver)
+ $(use_with xinerama)
--with-usbids=/usr/share/misc/usb.ids"
if use pam; then
diff --git a/kde-base/ksplashml/ChangeLog b/kde-base/ksplashml/ChangeLog
index fad190321a46..d45c896ffe4a 100644
--- a/kde-base/ksplashml/ChangeLog
+++ b/kde-base/ksplashml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksplashml
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ChangeLog,v 1.34 2005/12/17 10:23:15 corsair Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ChangeLog,v 1.35 2006/01/11 23:49:11 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/ksplashml-3.5.0-xinerama.patch, ksplashml-3.5.0.ebuild:
+ Added patch to disable xinerama support from ksplashml.
17 Dec 2005; Markus Rothe <corsair@gentoo.org> ksplashml-3.5.0.ebuild:
Added ~ppc64
diff --git a/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch b/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch
new file mode 100644
index 000000000000..4b824247e89b
--- /dev/null
+++ b/kde-base/ksplashml/files/ksplashml-3.5.0-xinerama.patch
@@ -0,0 +1,32 @@
+Index: kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in
+===================================================================
+--- kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (revision 497108)
++++ kdebase-3.5.0/ksplashml/themeengine/simple/configure.in.in (working copy)
+@@ -1,9 +1,13 @@
+-xinerama_save_ldflags="$LDFLAGS"
+-LDFLAGS="$X_LDFLAGS"
+-
+ LIB_XINERAMA=
+
+-KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
++AC_ARG_WITH([xinerama],
++ AS_HELP_STRING([--without-xinerama], [Disable xinerama extension support (default: check)]) )
++
++if test "x$with_xinerama" != "xno"; then
++ xinerama_save_ldflags="$LDFLAGS"
++ LDFLAGS="$X_LDFLAGS"
++
++ KDE_CHECK_HEADER(X11/extensions/Xinerama.h,
+ [
+ AC_CHECK_LIB(Xinerama,XineramaQueryExtension,
+ [
+@@ -17,5 +21,7 @@
+ #include <X11/Xlib.h>
+ ] )
+
+-AC_SUBST(LIB_XINERAMA)
+-LDFLAGS="$xinerama_save_ldflags"
++ AC_SUBST(LIB_XINERAMA)
++ LDFLAGS="$xinerama_save_ldflags"
++fi
++
diff --git a/kde-base/ksplashml/ksplashml-3.5.0.ebuild b/kde-base/ksplashml/ksplashml-3.5.0.ebuild
index b0707ac7eaf5..e985d5460ab3 100644
--- a/kde-base/ksplashml/ksplashml-3.5.0.ebuild
+++ b/kde-base/ksplashml/ksplashml-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.0.ebuild,v 1.4 2005/12/17 10:23:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.0.ebuild,v 1.5 2006/01/11 23:49:11 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -9,5 +9,18 @@ inherit kde-meta eutils
DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="xinerama"
+
+RDEPEND="xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )"
+
+PATCHES="${FILESDIR}/${P}-xinerama.patch"
+
+src_compile() {
+ myconf="${myconf} $(use_with xinerama)"
+
+ kde-meta_src_compile
+}