summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2010-04-11 09:59:18 +0000
committerAkinori Hattori <hattya@gentoo.org>2010-04-11 09:59:18 +0000
commitbe0cacf921abd330098739545f57fcc01b85c3a4 (patch)
treeacf0991df54a0c131347f166c0980e57135435bf /mail-client/sylpheed/sylpheed-3.0.2.ebuild
parentRemove old unused slot. (diff)
downloadhistorical-be0cacf921abd330098739545f57fcc01b85c3a4.tar.gz
historical-be0cacf921abd330098739545f57fcc01b85c3a4.tar.bz2
historical-be0cacf921abd330098739545f57fcc01b85c3a4.zip
new upstream release.
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'mail-client/sylpheed/sylpheed-3.0.2.ebuild')
-rw-r--r--mail-client/sylpheed/sylpheed-3.0.2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/mail-client/sylpheed/sylpheed-3.0.2.ebuild b/mail-client/sylpheed/sylpheed-3.0.2.ebuild
new file mode 100644
index 000000000000..71d662237634
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.0.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.0.2.ebuild,v 1.1 2010/04/11 09:59:18 hattya Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-1 )
+ ldap? ( net-nds/openldap )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/mime-types
+ net-misc/curl
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${PN}-2.[47]-*.diff
+ epatch "${FILESDIR}"/${PN}-3.*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautoreconf
+
+}
+
+src_configure() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck \
+ || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}