summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2012-12-03 12:13:46 +0000
committerAkinori Hattori <hattya@gentoo.org>2012-12-03 12:13:46 +0000
commit483e2af9431f86485838ec1484e9e717270b5b5b (patch)
tree72f770dfbbcf738d8c09d0efd57fdba0e3838213 /mail-client/sylpheed/sylpheed-3.3.0.ebuild
parentImprove the compatibility code thanks to Arfrever. (diff)
downloadhistorical-483e2af9431f86485838ec1484e9e717270b5b5b.tar.gz
historical-483e2af9431f86485838ec1484e9e717270b5b5b.tar.bz2
historical-483e2af9431f86485838ec1484e9e717270b5b5b.zip
new upstream release
Package-Manager: portage-2.1.11.31/cvs/Linux i686 Manifest-Sign-Key: 0xEC917A6D
Diffstat (limited to 'mail-client/sylpheed/sylpheed-3.3.0.ebuild')
-rw-r--r--mail-client/sylpheed/sylpheed-3.3.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/mail-client/sylpheed/sylpheed-3.3.0.ebuild b/mail-client/sylpheed/sylpheed-3.3.0.ebuild
new file mode 100644
index 000000000000..2cc17b99057c
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.3.0.ebuild,v 1.1 2012/12/03 12:13:41 hattya Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ nls? ( sys-devel/gettext )
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+}