summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-10 12:25:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-10 12:25:55 +0000
commit8021f69e055b09f591415fe32d2d87e67c4fcd11 (patch)
treec3574596b5f8d09ad2bb6c2aab44e2ce017f13fb /media-gfx/f-spot/files
parentInitial import of a flicrnet binary install; this is needed for the Flickr Ex... (diff)
downloadhistorical-8021f69e055b09f591415fe32d2d87e67c4fcd11.tar.gz
historical-8021f69e055b09f591415fe32d2d87e67c4fcd11.tar.bz2
historical-8021f69e055b09f591415fe32d2d87e67c4fcd11.zip
Fix flickr exporter (bug #283398 and more) by building against the system copy of flickrnet.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/f-spot/files')
-rw-r--r--media-gfx/f-spot/files/f-spot-0.6.1.1-use-system-flickrnet.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/f-spot/files/f-spot-0.6.1.1-use-system-flickrnet.patch b/media-gfx/f-spot/files/f-spot-0.6.1.1-use-system-flickrnet.patch
new file mode 100644
index 000000000000..6a24d3dbb7ce
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.6.1.1-use-system-flickrnet.patch
@@ -0,0 +1,30 @@
+Index: f-spot-0.6.1.1/extensions/Exporters/FlickrExport/Makefile.am
+===================================================================
+--- f-spot-0.6.1.1.orig/extensions/Exporters/FlickrExport/Makefile.am
++++ f-spot-0.6.1.1/extensions/Exporters/FlickrExport/Makefile.am
+@@ -20,16 +20,13 @@ REFS = \
+ $(LINK_GIOSHARP) \
+ $(LINK_GTKSHARPBEANS) \
+ $(LINK_DBUS) \
+- -r:FlickrNet/FlickrNet.dll \
++ -r:/usr/lib/mono/FlickrNet/FlickrNet.dll \
+ -r:Mono.Posix
+
+ PKGS = \
+ -pkg:gtk-sharp-2.0 \
+ -pkg:glade-sharp-2.0
+
+-SUBDIR = \
+- FlickrNet
+-
+ RESOURCES = \
+ -resource:$(srcdir)/$(PLUGIN_MANIFEST) \
+ -resource:$(srcdir)/$(PLUGIN_NAME).glade
+@@ -40,7 +37,6 @@ mpack: $(PLUGIN_ASSEMBLY)
+ mautil p $(PLUGIN_ASSEMBLY)
+
+ $(PLUGIN_ASSEMBLY): $(PLUGIN_SOURCES) $(PLUGIN_MANIFEST)
+- $(MAKE) -C $(SUBDIR)
+ $(CSC_LIB) -out:$@ $(PLUGIN_SOURCES) $(REFS) $(PKGS) $(ASSEMBLIES) $(RESOURCES)
+
+ plugindir = $(pkglibdir)/extensions