summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-07 22:48:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-07 22:48:58 +0000
commitfea622483f91fe2cc7edc6dfa0906f75b728306a (patch)
treee0a6d3f6e61c54c9da8cc170ce80fabd2dbc9c3a /media-gfx/gimp-print
parentUpdate to 0.9.0rc8a. (diff)
downloadhistorical-fea622483f91fe2cc7edc6dfa0906f75b728306a.tar.gz
historical-fea622483f91fe2cc7edc6dfa0906f75b728306a.tar.bz2
historical-fea622483f91fe2cc7edc6dfa0906f75b728306a.zip
touchups
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.2.ebuild32
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild39
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5.ebuild32
3 files changed, 22 insertions, 81 deletions
diff --git a/media-gfx/gimp-print/gimp-print-4.2.2.ebuild b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
index f3218ec83818..2f242c691ffa 100644
--- a/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
+++ b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
@@ -1,21 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.2.ebuild,v 1.9 2003/02/13 12:33:06 vapier Exp $
-
-IUSE="cups doc nls"
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.2.ebuild,v 1.10 2003/03/07 22:48:58 vapier Exp $
inherit libtool
-MY_P=${P}
-S=${WORKDIR}/${MY_P}
-
DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
-SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.gz"
HOMEPAGE="http://gimp-print.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc alpha sparc"
+IUSE="cups doc nls"
DEPEND="=x11-libs/gtk+-1.2*
=media-gfx/gimp-1.2*
@@ -26,29 +22,16 @@ DEPEND="=x11-libs/gtk+-1.2*
RDEPEND="virtual/glibc"
src_compile() {
-
elibtoolize
aclocal
- local myconf
-
- use cups && myconf="${myconf} --with-cups" \
- || myconf="${myconf} --without-cups"
-
- use nls && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- if [ -n "$DEBUG" ]; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
econf \
--with-ghost \
--sysconfdir=/etc/gimp/1.2/ \
--with-gimp-exec-prefix=/usr \
--with-testpattern \
+ `use_with cups` \
+ `use_enable nls` \
${myconf} || die
cp src/gimp/Makefile src/gimp/Makefile.orig
@@ -56,18 +39,16 @@ src_compile() {
src/gimp/Makefile.orig >src/gimp/Makefile
emake || die
-
}
src_install() {
-
dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
make \
DESTDIR=${D} \
HOME=/usr/lib/gimp/1.2 \
install || die "make install failed"
-
+
# NOTE: this build uses gimptool to install the plugin, so
# if we dont do it this way, it will install to / no
# matter what.
@@ -79,5 +60,4 @@ src_install() {
dodoc AUTHORS ChangeLog COPYING NEWS README*
dohtml -r doc
-
}
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild
index f365d71e7aa7..98b9893b7334 100644
--- a/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild
+++ b/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild
@@ -1,21 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild,v 1.1 2003/03/07 15:53:22 lordvan Exp $
-
-IUSE="cups doc nls"
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5-r1.ebuild,v 1.2 2003/03/07 22:48:58 vapier Exp $
inherit libtool
-MY_P=${P}
-S=${WORKDIR}/${MY_P}
-
DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
-SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.gz"
HOMEPAGE="http://gimp-print.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+IUSE="cups doc nls"
DEPEND="=x11-libs/gtk+-1.2*
>=media-gfx/gimp-1.2.3
@@ -26,44 +22,30 @@ DEPEND="=x11-libs/gtk+-1.2*
RDEPEND="virtual/glibc"
src_compile() {
-
elibtoolize
aclocal
- local myconf
-
- use cups && myconf="${myconf} --with-cups" \
- || myconf="${myconf} --without-cups"
-
- use nls && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- if [ -n "$DEBUG" ]; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- has_version =media-gfx/gimp-1.2* && \
- myconf='${myconf} --sysconfdir=/etc/gimp/1.2/' || \
- myconf='${myconf} --sysconfdir=/etc/gimp/1.3/'
+ local myconf=""
+ has_version =media-gfx/gimp-1.2* \
+ && myconf='${myconf} --sysconfdir=/etc/gimp/1.2/' \
+ || myconf='${myconf} --sysconfdir=/etc/gimp/1.3/'
econf \
--with-ghost \
--with-gimp-exec-prefix=/usr \
--with-testpattern \
+ `use_with cups` \
+ `use_enable nls` \
${myconf} || die
cp src/gimp/Makefile src/gimp/Makefile.orig
sed -e 's:--install-admin-bin:--install-bin:g' \
src/gimp/Makefile.orig >src/gimp/Makefile
-
- emake || die
+ emake || die
}
src_install() {
-
dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
make \
@@ -82,5 +64,4 @@ src_install() {
dodoc AUTHORS ChangeLog COPYING NEWS README*
dohtml -r doc
-
}
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
index c55b156ea22c..e7247bd1aa59 100644
--- a/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
+++ b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
@@ -1,21 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5.ebuild,v 1.4 2003/03/07 15:53:22 lordvan Exp $
-
-IUSE="cups doc nls"
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5.ebuild,v 1.5 2003/03/07 22:48:58 vapier Exp $
inherit libtool
-MY_P=${P}
-S=${WORKDIR}/${MY_P}
-
DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
-SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.gz"
HOMEPAGE="http://gimp-print.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc alpha ~sparc"
+IUSE="cups doc nls"
DEPEND="=x11-libs/gtk+-1.2*
=media-gfx/gimp-1.2*
@@ -26,41 +22,26 @@ DEPEND="=x11-libs/gtk+-1.2*
RDEPEND="virtual/glibc"
src_compile() {
-
elibtoolize
aclocal
- local myconf
-
- use cups && myconf="${myconf} --with-cups" \
- || myconf="${myconf} --without-cups"
-
- use nls && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- if [ -n "$DEBUG" ]; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
econf \
--with-ghost \
--sysconfdir=/etc/gimp/1.2/ \
--with-gimp-exec-prefix=/usr \
--with-testpattern \
- ${myconf} || die
+ `use_with cups` \
+ `use_enable nls` \
+ || die
cp src/gimp/Makefile src/gimp/Makefile.orig
sed -e 's:--install-admin-bin:--install-bin:g' \
src/gimp/Makefile.orig >src/gimp/Makefile
emake || die
-
}
src_install() {
-
dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
make \
@@ -79,5 +60,4 @@ src_install() {
dodoc AUTHORS ChangeLog COPYING NEWS README*
dohtml -r doc
-
}