summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-08-10 22:56:50 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-08-10 22:56:50 +0000
commit5b5c44aef9bc022c48842866ac2a69a52ddb872b (patch)
treee57279467cab72773522cf84c5ca2590ac0b243d /media-gfx/hugin
parentAdd berkdb to USE. Honor local USE=pop as well. Fix building when USE='-gdbm (diff)
downloadhistorical-5b5c44aef9bc022c48842866ac2a69a52ddb872b.tar.gz
historical-5b5c44aef9bc022c48842866ac2a69a52ddb872b.tar.bz2
historical-5b5c44aef9bc022c48842866ac2a69a52ddb872b.zip
initial commit of hugin, thanks to everyone on bug #48269
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/ChangeLog10
-rw-r--r--media-gfx/hugin/Manifest14
-rw-r--r--media-gfx/hugin/files/digest-hugin-0.5_rc11
-rw-r--r--media-gfx/hugin/hugin-0.5_rc1.ebuild59
-rw-r--r--media-gfx/hugin/metadata.xml10
5 files changed, 94 insertions, 0 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
new file mode 100644
index 000000000000..fa7a7d35dbaf
--- /dev/null
+++ b/media-gfx/hugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/hugin
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.1 2005/08/10 22:56:50 halcy0n Exp $
+
+*hugin-0.5_rc1 (10 Aug 2005)
+
+ 10 Aug 2005; Mark Loeser <halcy0n@gentoo.org> +metadata.xml,
+ +hugin-0.5_rc1.ebuild:
+ Initial commit of hugin. Thanks to everyone on bug #48269
+
diff --git a/media-gfx/hugin/Manifest b/media-gfx/hugin/Manifest
new file mode 100644
index 000000000000..dad960d159e5
--- /dev/null
+++ b/media-gfx/hugin/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 bf55a72f680b1b1879b7bcf232d16fcd hugin-0.5_rc1.ebuild 1560
+MD5 958a93f482686868d880a8b448d0899d metadata.xml 324
+MD5 b12bd3b15ca6a9436b5fe5c0472e9ce6 ChangeLog 384
+MD5 549db5b9b4146eb8aff8a35d39eabf1e files/digest-hugin-0.5_rc1 67
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFC+oZBCRZPokWLroQRAvUgAJ9WzlhHxIZzxf89HpsiUxhDLuQ8qgCfd/zG
+owf1NrVGKhBEaWqE79FsJxc=
+=tsPe
+-----END PGP SIGNATURE-----
diff --git a/media-gfx/hugin/files/digest-hugin-0.5_rc1 b/media-gfx/hugin/files/digest-hugin-0.5_rc1
new file mode 100644
index 000000000000..a4721551b398
--- /dev/null
+++ b/media-gfx/hugin/files/digest-hugin-0.5_rc1
@@ -0,0 +1 @@
+MD5 82fcd91f437b375438bee6f51352c777 hugin-0.5_rc1.tar.bz2 1499912
diff --git a/media-gfx/hugin/hugin-0.5_rc1.ebuild b/media-gfx/hugin/hugin-0.5_rc1.ebuild
new file mode 100644
index 000000000000..35116d488f30
--- /dev/null
+++ b/media-gfx/hugin/hugin-0.5_rc1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.5_rc1.ebuild,v 1.1 2005/08/10 22:56:50 halcy0n Exp $
+
+inherit wxwidgets
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+MY_P=${P/_rc*//}
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk2 unicode debug"
+
+DEPEND=">=media-libs/libpano12-2.7.0.8*
+ >=dev-libs/boost-1.30.0
+ >=x11-libs/wxGTK-2.6.0
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use unicode && ! use gtk2; then
+ die "You must put gtk2 in your USE if you want unicode."
+ fi
+}
+
+src_compile() {
+ export WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
+ elif ! use gtk2; then
+ need-wxwidgets gtk || die "Emerge wxGTK with wxgtk1 in USE"
+ else
+ need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
+ fi
+
+ myconf="`use_with unicode`
+ `use_enable debug`"
+
+ econf --with-wx-config="${WX_CONFIG}" ${myconf} || die "configure failed"
+ emake || die "compiling failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS BUGS INSTALL LICENCE LICENCE_SIFT README TODO
+}
+
+pkg_postinst() {
+ einfo "Please consider the helper apps autopano-sift and enblend."
+ einfo "autopano-sift is used to automagically generate control"
+ einfo "points and enblend is used to merge images smoothly."
+}
diff --git a/media-gfx/hugin/metadata.xml b/media-gfx/hugin/metadata.xml
new file mode 100644
index 000000000000..362b93a376a3
--- /dev/null
+++ b/media-gfx/hugin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<maintainer>
+ <email>halcy0n@gentoo.org</email>
+ <name>Mark Loeser</name>
+</maintainer>
+<longdescription>hugin is a panorama stitching program</longdescription>
+</pkgmetadata>