summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-07-05 00:29:21 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-07-05 00:29:21 +0000
commit870967ee4b0984437c1fb0466add2b8d898ef98b (patch)
treef9c07b7847c1cff72ad18e0cb1effba135d6fb35 /media-gfx/k3studio/k3studio-0.98.ebuild
parentnew version (diff)
downloadhistorical-870967ee4b0984437c1fb0466add2b8d898ef98b.tar.gz
historical-870967ee4b0984437c1fb0466add2b8d898ef98b.tar.bz2
historical-870967ee4b0984437c1fb0466add2b8d898ef98b.zip
new version (kde3-enabled)
Diffstat (limited to 'media-gfx/k3studio/k3studio-0.98.ebuild')
-rw-r--r--media-gfx/k3studio/k3studio-0.98.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/k3studio/k3studio-0.98.ebuild b/media-gfx/k3studio/k3studio-0.98.ebuild
new file mode 100644
index 000000000000..3d6d5cf8ab28
--- /dev/null
+++ b/media-gfx/k3studio/k3studio-0.98.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3studio/k3studio-0.98.ebuild,v 1.1 2002/07/05 00:29:21 verwilst Exp $
+
+inherit kde-base || die
+
+need-kde 3
+LICENSE="GPL-2"
+newdepend "=dev-lang/python-2.2*
+ >=media-libs/glut-3.7
+ >=sys-libs/readline-4.1
+ >=media-libs/freetype-2.0.5
+ >=media-libs/qhull-3.1"
+
+DESCRIPTION="KDE universal workbench for 2D/3D modeling, visualization and simulation."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://k3studio.sourceforge.net"
+
+src_compile() {
+ myconf="--with-qhull-includes=/usr/include/qhull"
+ myconf="$myconf --with-qhull-libraries=/usr/lib"
+ myconf="$myconf --with-python-includes=/usr/include/python2.2"
+ myconf="$myconf --with-python-libraries=\\\"-L. -L/usr/lib/python2.2/config `python-config`\\\""
+
+ kde_src_compile myconf
+ kde_src_compile configure
+ kde_src_compile make
+}