summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-07-23 23:23:15 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-07-23 23:23:15 +0000
commit3c6010add0f14b519762e34efd801257f077c405 (patch)
tree8ba8c1bfe97b0b5c072eede0978056b510cf8c4c /media-gfx/pixie/pixie-1.4.5.ebuild
parentFix typo; has_multlib_profile -> has_multilib_profile. (diff)
downloadhistorical-3c6010add0f14b519762e34efd801257f077c405.tar.gz
historical-3c6010add0f14b519762e34efd801257f077c405.tar.bz2
historical-3c6010add0f14b519762e34efd801257f077c405.zip
Version bump.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-gfx/pixie/pixie-1.4.5.ebuild')
-rw-r--r--media-gfx/pixie/pixie-1.4.5.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/pixie/pixie-1.4.5.ebuild b/media-gfx/pixie/pixie-1.4.5.ebuild
new file mode 100644
index 000000000000..53d71d75582a
--- /dev/null
+++ b/media-gfx/pixie/pixie-1.4.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-1.4.5.ebuild,v 1.1 2005/07/23 23:23:14 eradicator Exp $
+
+inherit eutils
+
+IUSE="X"
+
+MY_PN="Pixie"
+S="${WORKDIR}/${MY_PN}"
+
+DESCRIPTION="RenderMan like photorealistic renderer."
+HOMEPAGE="http://pixie.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-src-${PV}.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/jpeg
+ sys-libs/zlib
+ media-libs/tiff
+ X? ( virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ >=sys-devel/automake-1.8"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # These have been sent upstream, and rejected, but this is the
+ # "right way" -- eradicator
+ epatch ${FILESDIR}/${PN}-1.4.4-math.patch
+
+ # Make the build process more cross-platform...
+ epatch ${FILESDIR}/${PN}-1.4.4-libtool.patch
+
+ export WANT_AUTOMAKE=1.8
+ export WANT_AUTOCONF=2.5
+ libtoolize --force --copy || die
+ aclocal || die
+ automake -a -f -c || die
+ autoheader || die
+ autoconf || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ keepdir /usr/$(get_libdir)/Pixie/procedurals
+ keepdir /usr/share/Pixie/models
+
+ insinto /usr/share/Pixie/textures
+ doins ${S}/textures/checkers.tif
+
+ edos2unix ${D}/usr/share/Pixie/shaders/*
+ mv ${D}/usr/share/doc/Pixie ${D}/usr/share/doc/${PF}
+}