summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-12 04:16:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-12 04:16:31 +0000
commitf5e3381f6f71a2d6eb846ba953158450892573a3 (patch)
treed15d18fe2eb0bf1b3ad088b70c3edcb6d8d5899e /media-gfx/quat/quat-1.20.ebuild
parentfixed notification of ~/.canna (diff)
downloadhistorical-f5e3381f6f71a2d6eb846ba953158450892573a3.tar.gz
historical-f5e3381f6f71a2d6eb846ba953158450892573a3.tar.bz2
historical-f5e3381f6f71a2d6eb846ba953158450892573a3.zip
initial ebuild #27610
Diffstat (limited to 'media-gfx/quat/quat-1.20.ebuild')
-rw-r--r--media-gfx/quat/quat-1.20.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/quat/quat-1.20.ebuild b/media-gfx/quat/quat-1.20.ebuild
new file mode 100644
index 000000000000..6c0e5a54dd33
--- /dev/null
+++ b/media-gfx/quat/quat-1.20.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/quat/quat-1.20.ebuild,v 1.1 2003/09/12 04:16:31 vapier Exp $
+
+DESCRIPTION="A 3D quaternionic fractal generator"
+HOMEPAGE="http://www.physcip.uni-stuttgart.de/phy11733/quat_e.html"
+SRC_URI="http://www.physcip.uni-stuttgart.de/phy11733/download/quat-1.20.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="X? ( >=x11-libs/fltk-1.1 virtual/x11 )
+ >=sys-libs/zlib-1.1.4"
+RDEPEND=""
+
+src_compile() {
+ export FLUID=`which fluid` # needed because configure trys an invalid option
+ econf \
+ `use_enable X gui` \
+ `use_enable debug` \
+ `use_enable debug prof` \
+ || die "configure failure"
+ emake || die "make failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failure"
+ dodoc AUTHORS ChangeLog NEWS README
+}