summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-15 06:34:26 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-15 06:34:26 +0000
commita1c5d05b439ad8b9a5458d6e6dda2b56fb1d5386 (patch)
tree6e5f5225ce0fdee8aeaa19ca793912820e3e186f /media-gfx/sodipodi
parentbumped up release numbers of packages that were updated with the tcl/tk (diff)
downloadhistorical-a1c5d05b439ad8b9a5458d6e6dda2b56fb1d5386.tar.gz
historical-a1c5d05b439ad8b9a5458d6e6dda2b56fb1d5386.tar.bz2
historical-a1c5d05b439ad8b9a5458d6e6dda2b56fb1d5386.zip
fixed a typo, thanks tod, and removed old version
Diffstat (limited to 'media-gfx/sodipodi')
-rw-r--r--media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r31
-rw-r--r--media-gfx/sodipodi/sodipodi-0.24.1-r3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r3 b/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r3
new file mode 100644
index 000000000000..f2a01d628daa
--- /dev/null
+++ b/media-gfx/sodipodi/files/digest-sodipodi-0.24.1-r3
@@ -0,0 +1 @@
+MD5 1bb1c07993e6cee32ae2b2d8c39b9b40 sodipodi-0.24.1.tar.gz 1286144
diff --git a/media-gfx/sodipodi/sodipodi-0.24.1-r3.ebuild b/media-gfx/sodipodi/sodipodi-0.24.1-r3.ebuild
new file mode 100644
index 000000000000..38737b236d2a
--- /dev/null
+++ b/media-gfx/sodipodi/sodipodi-0.24.1-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sodipodi/sodipodi-0.24.1-r3.ebuild,v 1.1 2002/01/15 06:34:26 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Vector illustrating application for GNOME"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${A}"
+HOMEPAGE="http://sodipodi.sourceforge.net/"
+
+RDEPEND=">=gnome-base/gnome-print-0.30
+ >=gnome-extra/gal-0.13-r1
+ bonobo? ( >=gnome-base/bonobo-1.0.9 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-compile.patch
+ automake
+}
+
+src_compile() {
+ local myconf
+
+ myconf=""
+
+ # Bonobo support doesn't seem to work.
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ else
+ myconf="$myconf --without-bonobo"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --enable-gnome \
+ --enable-gnome-print \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+}