summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-25 21:38:42 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-25 21:38:42 +0000
commit0daf7af36ee1f2af2edacaa47cbfdfaf6f2e0a0c (patch)
treea986ed36f340005627da0cf8b88d19478f6ebde7 /media-gfx/xv
parentFixing path to generate-asm and asm_offsets.h after kernel ebuild (diff)
downloadhistorical-0daf7af36ee1f2af2edacaa47cbfdfaf6f2e0a0c.tar.gz
historical-0daf7af36ee1f2af2edacaa47cbfdfaf6f2e0a0c.tar.bz2
historical-0daf7af36ee1f2af2edacaa47cbfdfaf6f2e0a0c.zip
fixor - closes bug #2101
Diffstat (limited to 'media-gfx/xv')
-rw-r--r--media-gfx/xv/ChangeLog6
-rw-r--r--media-gfx/xv/files/xv.diff21
-rw-r--r--media-gfx/xv/xv-3.10a.ebuild29
3 files changed, 29 insertions, 27 deletions
diff --git a/media-gfx/xv/ChangeLog b/media-gfx/xv/ChangeLog
index fc3dcbb2c13d..9d85a98ca53d 100644
--- a/media-gfx/xv/ChangeLog
+++ b/media-gfx/xv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/xv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.2 2002/04/25 21:38:42 bangert Exp $
+
+ 25 Apr 2002; Thilo Bangert <bangert@gentoo.org> :
+
+ switched to || die - added description
*xv-3.10a (1 Feb 2002)
diff --git a/media-gfx/xv/files/xv.diff b/media-gfx/xv/files/xv.diff
index 166170469768..d4101f991c4e 100644
--- a/media-gfx/xv/files/xv.diff
+++ b/media-gfx/xv/files/xv.diff
@@ -4,27 +4,18 @@ diff -Nu xv-3.10a.clean/Makefile xv-3.10a/Makefile
+++ xv-3.10a/Makefile Sat Jul 21 12:43:52 2001
@@ -1,8 +1,8 @@
# Makefile for xv
-
+
# your C compiler (and options) of choice
-CC = cc
-# CC = gcc -ansi
+#CC = cc
+CC = gcc -ansi
-
+
# use this if you're using 'cc' on a DEC Alpha (OSF/1) or MIPS (Ultrix) system:
# CC = cc -std1 -Olimit 750
-@@ -14,7 +14,7 @@
- # -Wuninitialized -Wparentheses
-
-
--CCOPTS = -O
-+CCOPTS = -O3 -march=i686 -mcpu=i686
-
-
- ### NOTE: Sun running OpenWindows:
@@ -28,10 +28,11 @@
-
-
+
+
### Installation locations
-BINDIR = /usr/local/bin
-MANDIR = /usr/local/man/man1
@@ -34,8 +25,8 @@ diff -Nu xv-3.10a.clean/Makefile xv-3.10a/Makefile
-LIBDIR = /usr/local/lib
+LIBDIR = /usr/lib
+DOCDIR = /usr/share/doc/xv-3.10a
-
-
+
+
buildit: all
@@ -59,12 +60,12 @@
### if, for whatever reason, you're unable to get the TIFF library to compile
diff --git a/media-gfx/xv/xv-3.10a.ebuild b/media-gfx/xv/xv-3.10a.ebuild
index dcf1b20734cd..024301f7d435 100644
--- a/media-gfx/xv/xv-3.10a.ebuild
+++ b/media-gfx/xv/xv-3.10a.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <lamer@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a.ebuild,v 1.2 2002/03/06 18:55:22 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a.ebuild,v 1.3 2002/04/25 21:38:42 bangert Exp $
S=${WORKDIR}/${P}
-DESCRIPTION="This is a sample skeleton ebuild file"
+DESCRIPTION="xv - image viewer for X"
SRC_URI="ftp://ftp.cis.upenn.edu/pub/xv/${P}.tar.gz"
HOMEPAGE="http://www.trilon.com/xv/index.html"
DEPEND="virtual/x11
@@ -17,23 +17,30 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
cd ${S}
-# I know very little about make but somehow I was able to riddle out how to
-# fix this makefile so it not unly understood DESTDIR but makes it's own
-# dirs to. I fail to understand why people can't seem to do that. Do they
-# want packagers to have a hard time with thier source trees?
+
+ mv Makefile Makefile.orig
+
+
+ sed -e "s:^CCOPTS.*:CCOPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+
+ # I know very little about make but somehow I was able to riddle out how to
+ # fix this makefile so it not unly understood DESTDIR but makes it's own
+ # dirs to. I fail to understand why people can't seem to do that. Do they
+ # want packagers to have a hard time with thier source trees?
patch -p1 < ${FILESDIR}/xv.diff
}
src_compile() {
-
+
# try emake
- try make
+ make || die
}
src_install () {
-
- try make DESTDIR=${D} install
- dodoc README INSTALL CHANGELOG BUGS IDEAS
+ make DESTDIR=${D} install || die
+
+ dodoc README INSTALL CHANGELOG BUGS IDEAS
}