summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-22 00:42:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-22 00:42:08 +0000
commit7b9d4134999c2b6445c91e36837073f2319b86d3 (patch)
tree151b9978d8c4a6134fb9b94b412e6dce7870aa97 /media-libs/allegro/allegro-4.0.3.ebuild
parentadded lestiff dep to beta ebuilds (diff)
downloadhistorical-7b9d4134999c2b6445c91e36837073f2319b86d3.tar.gz
historical-7b9d4134999c2b6445c91e36837073f2319b86d3.tar.bz2
historical-7b9d4134999c2b6445c91e36837073f2319b86d3.zip
real fix for #26031
Diffstat (limited to 'media-libs/allegro/allegro-4.0.3.ebuild')
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
index 26d4283a901d..d3059e619b39 100644
--- a/media-libs/allegro/allegro-4.0.3.ebuild
+++ b/media-libs/allegro/allegro-4.0.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.3 2003/08/21 02:38:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.4 2003/08/22 00:42:08 vapier Exp $
inherit flag-o-matic
-filter-flags -fPIC -fprefetch-loop-arrays
+filter-flags -fPIC
DESCRIPTION="cross-platform multimedia library"
SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
@@ -22,6 +22,11 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
DEPEND="${RDEPEND}
tetex? ( app-text/tetex )"
+src_unpack() {
+ unpack ${A}
+ sed -i '/TARGET_ARCH=/s:=.*:=:' ${S}/configure || die 'couldnt remove pentium cpu'
+}
+
src_compile() {
econf \
--enable-linux \