summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-06-01 14:46:55 +0000
committerThomas Sachau <tommy@gentoo.org>2014-06-01 14:46:55 +0000
commit9e4aa670f8b2ad0980f002bff6220f4c8bc4cdf0 (patch)
tree77185e166c37dcdfa7f29c25516638739ae5eac7 /media-libs/elementary/elementary-1.9.4.ebuild
parentVersion bump to 1.7.17, fixes bug 506308 (diff)
downloadhistorical-9e4aa670f8b2ad0980f002bff6220f4c8bc4cdf0.tar.gz
historical-9e4aa670f8b2ad0980f002bff6220f4c8bc4cdf0.tar.bz2
historical-9e4aa670f8b2ad0980f002bff6220f4c8bc4cdf0.zip
Version bump, disable build of examples for bug 510428, drop old
Package-Manager: portage-2.2.6-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x35899067
Diffstat (limited to 'media-libs/elementary/elementary-1.9.4.ebuild')
-rw-r--r--media-libs/elementary/elementary-1.9.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/elementary/elementary-1.9.4.ebuild b/media-libs/elementary/elementary-1.9.4.ebuild
new file mode 100644
index 000000000000..bc80d579ae2c
--- /dev/null
+++ b/media-libs/elementary/elementary-1.9.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/elementary/elementary-1.9.4.ebuild,v 1.1 2014/06/01 14:46:46 tommy Exp $
+
+EAPI=5
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/libs/${PN}/${MY_P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Basic widget set, based on EFL for mobile touch-screen devices."
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Elementary"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug examples fbcon quicklaunch sdl wayland X static-libs"
+
+DEPEND="
+ >=dev-libs/efl-1.9.2[sdl?,png,wayland?,X?]
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable debug)
+ $(use_enable doc)
+ --disable-ecore-cocoa
+ --disable-ecore-psl1ght
+ --disable-ecore-win32
+ --disable-ecore-wince
+ --disable-elocation
+ --disable-emap
+ --disable-eweather
+ $(use_enable examples install-examples)
+ $(use_enable fbcon ecore-fb)
+ $(use_enable sdl ecore-sdl)
+ $(use_enable wayland ecore-wayland)
+ $(use_enable X ecore-x)
+ $(use_enable quicklaunch quick-launch)
+ "
+#broken: make[4]: *** No rule to make target 'prefs_example_01.epb', needed by 'all-am'. Stop
+# $(use_enable examples build-examples)
+
+ enlightenment_src_configure
+}