summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-22 14:37:06 +0000
commit43480cafff7d0e6202a391ad867fa8b9ecf05673 (patch)
tree28c65e3696f5ac45856b3fd377e0ca74cd88cd6d /media-libs/flac/flac-1.0.3.ebuild
parentadded 3dfx's GPL (diff)
downloadhistorical-43480cafff7d0e6202a391ad867fa8b9ecf05673.tar.gz
historical-43480cafff7d0e6202a391ad867fa8b9ecf05673.tar.bz2
historical-43480cafff7d0e6202a391ad867fa8b9ecf05673.zip
repoman'd
Diffstat (limited to 'media-libs/flac/flac-1.0.3.ebuild')
-rw-r--r--media-libs/flac/flac-1.0.3.ebuild41
1 files changed, 26 insertions, 15 deletions
diff --git a/media-libs/flac/flac-1.0.3.ebuild b/media-libs/flac/flac-1.0.3.ebuild
index 023da8a5527c..7fbf57bfaa57 100644
--- a/media-libs/flac/flac-1.0.3.ebuild
+++ b/media-libs/flac/flac-1.0.3.ebuild
@@ -1,34 +1,45 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.0.3.ebuild,v 1.1 2002/07/08 22:58:10 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.0.3.ebuild,v 1.2 2002/07/22 14:37:06 seemant Exp $
DESCRIPTION="A free lossless audio encoder"
SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
HOMEPAGE="http://flac.sourceforge.net/"
-#flac has an optional xmms plugin. For now, we just depend on xmms. We can optimize this later.
-RDEPEND="virtual/glibc X? ( >=media-sound/xmms-1.2.5-r2 ) >=media-libs/libogg-1.0_rc2"
-DEPEND="virtual/glibc dev-lang/nasm sys-apps/gawk $RDEPEND"
-KEYWORDS="*"
-LICENSE="GPL-2 LGPL-2"
+
SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/glibc
+ >=media-libs/libogg-1.0_rc2
+ xmms? ( media-sound/xmms )"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ sys-apps/gawk"
src_compile() {
- cd ${S}
- local myflags
- [ `use sse` ] && myflags="--enable-sse"
+ local myconf
+
+ use sse && myconf="--enable-sse"
+
#--use-3dnow is documented but apparently not yet enabled.
- #[ `use 3dnow` ] && myflags="$myflags --use-3dnow"
- ./configure --prefix=/usr $myflags --host=$CHOST || die
+ #use 3dnow && myconf="${myconf} --use-3dnow"
+
+ econf ${myconf} || die
cp Makefile Makefile.orig
+
#the man page ebuild requires docbook2man... yick!
sed -e 's:include man:include:g' Makefile.orig > Makefile
+
#emake seems to mess up the building of the xmms input plugin
make || die
}
src_install() {
#it looks like we need to run the xmms install first
- ( cd src/plugin_xmms; make DESTDIR=${D} install )
+ cd src/plugin_xmms
make DESTDIR=${D} install
-}
-
+ cd ${S}
+ make DESTDIR=${D} install
+}