summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-08 02:10:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-08 02:10:12 +0000
commite4c725464f2176c574cd24f91a753141b8a07c8c (patch)
tree87df3c41d9fe3c1b3797dbec8389f0eae5999370 /media-libs/nas/nas-1.5.ebuild
parentnew digests (diff)
downloadhistorical-e4c725464f2176c574cd24f91a753141b8a07c8c.tar.gz
historical-e4c725464f2176c574cd24f91a753141b8a07c8c.tar.bz2
historical-e4c725464f2176c574cd24f91a753141b8a07c8c.zip
version bump
Diffstat (limited to 'media-libs/nas/nas-1.5.ebuild')
-rw-r--r--media-libs/nas/nas-1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/nas/nas-1.5.ebuild b/media-libs/nas/nas-1.5.ebuild
new file mode 100644
index 000000000000..b9fa55a6af13
--- /dev/null
+++ b/media-libs/nas/nas-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/nas/nas-1.5.ebuild,v 1.1 2002/06/08 02:10:12 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Audio System"
+SRC_URI="http://radscan.com/nas/${P}.src.tar.gz"
+HOMEPAGE="http://radscan.com/nas.html"
+
+SLOT="0"
+LICENSE="X11"
+
+# This is ridculuous, we only need xmkmf, but no other package
+# provides it. 20020607 (Seemant): Actually, the homepage says it needs
+# the entire X11 build environment, so this is ok.
+DEPEND=">=x11-base/xfree-4"
+
+src_compile() {
+
+ xmkmf
+ touch doc/man/lib/tmp.{_man,man}
+ emake World || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install.man || die
+
+ for i in ${D}/usr/X11R6/man/man?/*.?x
+ do
+ gzip -9 $i
+ done
+
+ dodoc BUGS BUILDNOTES FAQ HISTORY README RELEASE TODO
+ mv ${D}/usr/X11R6/lib/X11/doc/html ${D}/usr/share/doc/${P}/
+ rmdir ${D}/usr/X11R6/lib/X11/doc
+
+
+}
+