summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-04-23 03:27:28 +0000
committerRyan Hill <rhill@gentoo.org>2007-04-23 03:27:28 +0000
commit6cdd64d036589573eb8c7574dac5b616b4f1fe5b (patch)
tree415b8ea552396d80875212d2ebe9efc2347e316a /media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
parentSome more tweaks but still not 100% (diff)
downloadhistorical-6cdd64d036589573eb8c7574dac5b616b4f1fe5b.tar.gz
historical-6cdd64d036589573eb8c7574dac5b616b4f1fe5b.tar.bz2
historical-6cdd64d036589573eb8c7574dac5b616b4f1fe5b.zip
Add patch to allow building with later freetype versions. Bug #175640.
Package-Manager: portage-2.1.2.4
Diffstat (limited to 'media-libs/wxsvg/wxsvg-1.0_beta7.ebuild')
-rw-r--r--media-libs/wxsvg/wxsvg-1.0_beta7.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild b/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
index 9dcbe3c0b93d..44f5a43f0f49 100644
--- a/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
+++ b/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild,v 1.1 2007/01/28 20:02:38 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0_beta7.ebuild,v 1.2 2007/04/23 03:27:28 dirtyepic Exp $
inherit eutils wxwidgets
@@ -26,6 +26,13 @@ DEPEND="=x11-libs/wxGTK-2.6*
S=${WORKDIR}/${PN}-${MY_PV}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-freetype.patch
+}
+
src_compile() {
export WX_GTK_VER="2.6"
need-wxwidgets gtk2