summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-20 20:41:27 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-20 20:41:27 +0000
commit3e808084e3ef3a06d4436c48bdb08ad0b31d1082 (patch)
tree9739d864119f8b281431ead07b3f7db8da9ad0c5 /media-libs
parentgnome2 fixes (diff)
downloadhistorical-3e808084e3ef3a06d4436c48bdb08ad0b31d1082.tar.gz
historical-3e808084e3ef3a06d4436c48bdb08ad0b31d1082.tar.bz2
historical-3e808084e3ef3a06d4436c48bdb08ad0b31d1082.zip
gnome2 fixes
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/SoGtk/SoGtk-20010601-r1.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/media-libs/SoGtk/SoGtk-20010601-r1.ebuild b/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
index 362d14ec8a72..0c127bad6a06 100644
--- a/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
+++ b/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
@@ -2,36 +2,43 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
# Maintainer: Desktop Team <desktop@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/SoGtk-20010601-r1.ebuild,v 1.3 2001/12/29 17:41:37 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/SoGtk-20010601-r1.ebuild,v 1.4 2002/06/20 20:41:27 azarah Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="A Gtk Interface for coin"
SRC_URI="ftp://ftp.coin3d.org/pub/snapshots/${P}.tar.gz"
HOMEPAGE="http://www.coin3d.org"
+SLOT="0"
-DEPEND="virtual/x11 sys-devel/autoconf sys-devel/automake sys-devel/libtool
- >=x11-libs/gtkglarea-1.2.2
- ~media-libs/coin-${PV}"
+DEPEND="virtual/x11
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool
+ <x11-libs/gtkglarea-1.99.0
+ ~media-libs/coin-${PV}"
RDEPEND="virtual/x11
- >=x11-libs/gtkglarea-1.2.2
- ~media-libs/coin-${PV}"
+ <x11-libs/gtkglarea-1.99.0
+ ~media-libs/coin-${PV}"
+
src_compile() {
./bootstrap --add
- try ./configure --prefix=/usr --host=${CHOST} --build=${CHOST}
- try make
-
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --build=${CHOST} || die
+
+ make || die
}
src_install () {
- try make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
+
cd ${S}
dodoc AUTHORS COPYING ChangeLog* LICENSE* NEWS README*
docinto txt
dodoc docs/qtcomponents.doxygen
-
}