summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:44:30 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-08 23:44:30 +0000
commita22a242441f1377698101fa727dbcd8dde350187 (patch)
tree08fd0d71710dd261e034cc11e0870dae933adcfb /media-plugins/mythgallery
parentinitial check-in (diff)
downloadhistorical-a22a242441f1377698101fa727dbcd8dde350187.tar.gz
historical-a22a242441f1377698101fa727dbcd8dde350187.tar.bz2
historical-a22a242441f1377698101fa727dbcd8dde350187.zip
initial check-in
Diffstat (limited to 'media-plugins/mythgallery')
-rw-r--r--media-plugins/mythgallery/Manifest4
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.101
-rw-r--r--media-plugins/mythgallery/mythgallery-0.10.ebuild70
3 files changed, 73 insertions, 2 deletions
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index 3b17f72f9db0..be9989580aa0 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -1,3 +1,3 @@
-MD5 639b9cfa61395f7523078b365701a4f0 mythgallery-0.10.ebuild 1698
-MD5 ba1ca00111cfc2474ec3667f21986834 ChangeLog 1245
+MD5 938be6b2c1301c8651915380520bce14 mythgallery-0.10.ebuild 1707
+MD5 bf66a8bd468e4b7479d457bcfb5d48da ChangeLog 1254
MD5 08ad7857fea9bfc28178d4e14aa3ae10 files/digest-mythgallery-0.10 67
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.10 b/media-plugins/mythgallery/files/digest-mythgallery-0.10
new file mode 100644
index 000000000000..9ca448b677b3
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.10
@@ -0,0 +1 @@
+MD5 803f2962370f5d34de084e33e21e7738 mythgallery-0.10.tar.bz2 9964
diff --git a/media-plugins/mythgallery/mythgallery-0.10.ebuild b/media-plugins/mythgallery/mythgallery-0.10.ebuild
new file mode 100644
index 000000000000..428521b98d2c
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.10.ebuild,v 1.1 2003/07/08 23:41:19 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins database/*.sql
+
+ dodoc COPYING README UPGRADING
+
+}
+
+pkg_postinst() {
+
+ einfo "If this is the first time you install MythGallery,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/gallery.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/gallery.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+
+}