summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2010-12-26 22:55:44 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2010-12-26 22:55:44 +0000
commit2b8e03cec85ceda0624eb3e029ef5e70f9cebb0c (patch)
treef80ca5ce4c577ce78522cea64a6daf4eb6d5f3eb /media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild
parentBug #349083: Fix a false positive in the Git testsuite, triggered when the po... (diff)
downloadhistorical-2b8e03cec85ceda0624eb3e029ef5e70f9cebb0c.tar.gz
historical-2b8e03cec85ceda0624eb3e029ef5e70f9cebb0c.tar.bz2
historical-2b8e03cec85ceda0624eb3e029ef5e70f9cebb0c.zip
fix #349793; some minor ebuild fixes
Package-Manager: portage-2.1.9.24/cvs/Linux i686
Diffstat (limited to 'media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild')
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild
index 5767d2ef6014..8fdcb045f2bc 100644
--- a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild,v 1.1 2010/12/03 14:37:51 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.8.ebuild,v 1.2 2010/12/26 22:55:44 hd_brummy Exp $
EAPI="2"
@@ -18,6 +18,7 @@ IUSE=""
DEPEND=">=media-video/vdr-1.6
>=app-misc/graphlcd-base-0.1.7"
+RDEPEND="${DEPEND}"
pkg_setup() {
vdr-plugin_pkg_setup
@@ -42,9 +43,16 @@ src_prepare() {
vdr-plugin_src_prepare
sed -i "s:/usr/local:/usr:" Makefile
+
+ sed -i "s:i18n.c:i18n.h:g" Makefile
+
+ if ! has_version ">=media-video/vdr-1.7.13"; then
+ sed -i "s:include \$(VDRDIR)/Make.global:#include \$(VDRDIR)/Make.global:" Makefile
+ fi
}
src_install() {
+
vdr-plugin_src_install
insopts -m0644 -ovdr -gvdr