summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2008-06-22 17:43:35 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2008-06-22 17:43:35 +0000
commit994fa72bd07be4df6f39fce77b0fd86d267aa117 (patch)
tree3dba6f124d1baea74b2bb62650ed046b41ba00ff /media-plugins/vdr-graphtft/files
parentAdd ~sparc keyword (diff)
downloadhistorical-994fa72bd07be4df6f39fce77b0fd86d267aa117.tar.gz
historical-994fa72bd07be4df6f39fce77b0fd86d267aa117.tar.bz2
historical-994fa72bd07be4df6f39fce77b0fd86d267aa117.zip
add patches to compile with new header structur of imagemagick-6.4.x and gcc-4.3.x
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'media-plugins/vdr-graphtft/files')
-rw-r--r--media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff11
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff14
2 files changed, 25 insertions, 0 deletions
diff --git a/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff b/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff
new file mode 100644
index 000000000000..c5124bd445c2
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/gcc-4.3-missing_includes.diff
@@ -0,0 +1,11 @@
+diff -Naur graphtft-0.1.18.alpha.orig/tcpchannel.c graphtft-0.1.18.alpha/tcpchannel.c
+--- graphtft-0.1.18.alpha.orig/tcpchannel.c 2008-06-22 19:32:19.000000000 +0200
++++ graphtft-0.1.18.alpha/tcpchannel.c 2008-06-22 19:32:59.000000000 +0200
+@@ -15,6 +15,7 @@
+ #include <fcntl.h>
+ #include <netdb.h>
+ #include <errno.h>
++#include <string.h>
+
+ #include "tcpchannel.h"
+ #include "common.h"
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff
new file mode 100644
index 000000000000..e071e6765bb5
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-imagemagick-6.4-new_header.diff
@@ -0,0 +1,14 @@
+diff -Naur graphtft-0.1.18.alpha.orig/Makefile graphtft-0.1.18.alpha/Makefile
+--- graphtft-0.1.18.alpha.orig/Makefile 2008-06-22 19:12:45.000000000 +0200
++++ graphtft-0.1.18.alpha/Makefile 2008-06-22 19:16:56.000000000 +0200
+@@ -122,6 +122,10 @@
+ HAVE_FFMPEG = 1
+ endif
+
++ifdef HAVE_IMAGE_MAGICK
++ INCLUDES += -I/usr/include/ImageMagick
++endif
++
+ ifdef HAVE_GTOP
+ GTOP_INC = `pkg-config libgtop-2.0 --cflags`
+ GTOP_LIB = `pkg-config libgtop-2.0 --libs`