summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-12 02:58:43 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-12 02:58:43 +0000
commita5530e9f304a18463814f5f0285dbbd6523967b5 (patch)
tree23f59982aecec7d4ed59be7c88d213b8c00ccb5a /media-plugins
parentUpdated to work with new aolserver.eclass changes (diff)
downloadhistorical-a5530e9f304a18463814f5f0285dbbd6523967b5.tar.gz
historical-a5530e9f304a18463814f5f0285dbbd6523967b5.tar.bz2
historical-a5530e9f304a18463814f5f0285dbbd6523967b5.zip
Fix global scope use_enable.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild8
-rw-r--r--media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild8
-rw-r--r--media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild7
-rw-r--r--media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild8
-rw-r--r--media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild9
-rw-r--r--media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild9
6 files changed, 36 insertions, 13 deletions
diff --git a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
index c9b1432e8fbb..7003a242a9a9 100644
--- a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
+++ b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.1 2005/02/12 02:26:04 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10-r1.ebuild,v 1.2 2005/02/12 02:58:43 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -12,7 +12,11 @@ PATCH_VER="2.2.2"
PLUGIN_PATH="Input/cdaudio"
-myconf="--enable-cdaudio `use_enable ipv6`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-cdaudio $(use_enable ipv6)"
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
index 22e16eecb6ab..3282b4f4f03b 100644
--- a/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
+++ b/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild,v 1.1 2005/02/12 02:26:04 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-cdaudio/xmms-cdaudio-1.2.10.ebuild,v 1.2 2005/02/12 02:58:43 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -10,7 +10,11 @@ DEPEND=">=media-sound/xmms-1.2.10"
PLUGIN_PATH="Input/cdaudio"
-myconf="--enable-cdaudio `use_enable ipv6`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-cdaudio $(use_enable ipv6)"
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild
index 1ca43d50df5a..86ae5adaf9c4 100644
--- a/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild
+++ b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild,v 1.1 2005/02/12 02:22:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10-r1.ebuild,v 1.2 2005/02/12 02:56:03 eradicator Exp $
IUSE="ipv6 ssl"
SLOT="0"
@@ -17,3 +17,8 @@ myconf="--enable-mpg123 `use_enable ipv6` `use_enable ssl`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-mpg123 $(use_enable ipv6) $(use_enable ssl)"
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild
index 9d1e3722c4ae..8ec3490b19ff 100644
--- a/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild
+++ b/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild,v 1.1 2005/02/12 02:22:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-mpg123/xmms-mpg123-1.2.10.ebuild,v 1.2 2005/02/12 02:56:03 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -10,7 +10,11 @@ DEPEND=">=media-sound/xmms-1.2.10"
PLUGIN_PATH="Input/mpg123"
-myconf="--enable-mpg123 `use_enable ipv6`"
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-mpg123 $(use_enable ipv6)"
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild b/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild
index 8da1574d2747..9ea5f9126233 100644
--- a/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild
+++ b/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild,v 1.2 2005/02/12 02:16:18 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10-r1.ebuild,v 1.3 2005/02/12 02:53:04 eradicator Exp $
IUSE="ipv6 ssl"
SLOT="0"
@@ -14,8 +14,11 @@ PATCH_VER="2.2.2"
PLUGIN_PATH="Input/vorbis"
-myconf="--enable-vorbis `use_enable ipv6` `use_enable ssl`"
-
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-vorbis `use_enable ipv6``use_enable ssl` "
+ xmms-plugin_src_compile
+}
diff --git a/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild b/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild
index b8e6e3347d18..24a5051689ae 100644
--- a/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild
+++ b/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild,v 1.2 2005/02/12 02:16:18 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-vorbis/xmms-vorbis-1.2.10.ebuild,v 1.3 2005/02/12 02:53:04 eradicator Exp $
IUSE="ipv6"
SLOT="0"
@@ -11,8 +11,11 @@ DEPEND=">=media-sound/xmms-1.2.10
PLUGIN_PATH="Input/vorbis"
-myconf="--enable-vorbis `use_enable ipv6`"
-
M4_VER="1.0"
inherit xmms-plugin
+
+src_compile() {
+ myconf="${myconf} --enable-vorbis `use_enable ipv6`"
+ xmms-plugin_src_compile
+}