summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:25:54 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:25:54 +0000
commite6964dda897b6eed5bafd11af8193481ca5ce12e (patch)
treec925718fb76d3d126fe276a9ad8320b83d12f01d /media-plugins
parentBump to version 0.12. Add support for alsa, lcd, lirc, xvmc. Add Qt mysql sup... (diff)
downloadhistorical-e6964dda897b6eed5bafd11af8193481ca5ce12e.tar.gz
historical-e6964dda897b6eed5bafd11af8193481ca5ce12e.tar.bz2
historical-e6964dda897b6eed5bafd11af8193481ca5ce12e.zip
Bump to version 0.12. Add support for alsa, lirc, and vcd.
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythdvd/ChangeLog7
-rw-r--r--media-plugins/mythdvd/Manifest4
-rw-r--r--media-plugins/mythdvd/files/digest-mythdvd-0.121
-rw-r--r--media-plugins/mythdvd/mythdvd-0.12.ebuild82
4 files changed, 92 insertions, 2 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index d48641b52e42..afc82a81356f 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.2 2003/09/17 06:32:55 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.3 2003/10/20 03:25:53 max Exp $
+
+*mythdvd-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythdvd-0.12.ebuild:
+ Bump to version 0.12. Add support for alsa, lirc, and vcd.
16 Sep 2003; Max Kalika <max@gentoo.org> mythdvd-0.11.ebuild:
Bump to stable.
diff --git a/media-plugins/mythdvd/Manifest b/media-plugins/mythdvd/Manifest
index 8082243fb1eb..c02a4de064fc 100644
--- a/media-plugins/mythdvd/Manifest
+++ b/media-plugins/mythdvd/Manifest
@@ -1,4 +1,6 @@
MD5 00fc0fff830f25508d04a99963a988fc mythdvd-0.11.ebuild 1962
-MD5 11830c5e52c5af52ce5e7d6ee5581276 ChangeLog 417
+MD5 48f09e2e822d95db6cee31c658a96119 mythdvd-0.12.ebuild 2357
+MD5 cfb665ed74c99aeec820543235a617ba ChangeLog 572
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 29d1ec475eee7e6e4d5b6a605611c4c7 files/digest-mythdvd-0.11 64
+MD5 43523be8d2e4958df76e6e1b2b63791c files/digest-mythdvd-0.12 65
diff --git a/media-plugins/mythdvd/files/digest-mythdvd-0.12 b/media-plugins/mythdvd/files/digest-mythdvd-0.12
new file mode 100644
index 000000000000..c393d99b65da
--- /dev/null
+++ b/media-plugins/mythdvd/files/digest-mythdvd-0.12
@@ -0,0 +1 @@
+MD5 877a5746006e27267c5119777f52dd86 mythdvd-0.12.tar.bz2 112111
diff --git a/media-plugins/mythdvd/mythdvd-0.12.ebuild b/media-plugins/mythdvd/mythdvd-0.12.ebuild
new file mode 100644
index 000000000000..789096547f2a
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.12.ebuild,v 1.1 2003/10/20 03:25:53 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="DVD player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="alsa lirc transcode"
+
+DEPEND="media-libs/libdvdread
+ >=sys-apps/sed-4
+ >=media-plugins/mythvideo-${PV}
+ transcode? ( media-video/transcode )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf="--enable-vcd"
+ myconf="${myconf} `use_enable transcode`"
+
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ if [ "`use alsa`" ] ; then
+ echo "CONFIG += using_alsa" >> settings.pro
+ echo "EXTRA_LIBS += -lasound" >> settings.pro
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins dvddb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc dvddb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythDVD,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}