summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-19 12:27:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-19 12:27:52 +0000
commit493b601e5b94d314f46cb151c7ca3e24058e3eb7 (patch)
tree1d0b55b7729a0b2051060e165ee449bb6dde7367 /media-sound/alsa-tools
parentAdded LICENSE, SLOT, KEYWORDS (diff)
downloadhistorical-493b601e5b94d314f46cb151c7ca3e24058e3eb7.tar.gz
historical-493b601e5b94d314f46cb151c7ca3e24058e3eb7.tar.bz2
historical-493b601e5b94d314f46cb151c7ca3e24058e3eb7.zip
repoman'd
Diffstat (limited to 'media-sound/alsa-tools')
-rw-r--r--media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild52
-rw-r--r--media-sound/alsa-tools/alsa-tools-0.9.0_rc1.ebuild50
-rw-r--r--media-sound/alsa-tools/files/digest-alsa-tools-0.9.0_rc11
3 files changed, 27 insertions, 76 deletions
diff --git a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild b/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
index 9285eea08682..b6067f94d1a7 100644
--- a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild,v 1.2 2002/07/11 06:30:40 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild,v 1.3 2002/07/19 12:27:49 seemant Exp $
+S="${WORKDIR}/${P/_rc/rc}"
DESCRIPTION="Advanced Linux Sound Architecture tools"
HOMEPAGE="http://www.alsa-project.org"
-
SRC_URI="ftp://ftp.alsa-project.org/pub/tools/${P/_rc/rc}.tar.bz2"
-S="${WORKDIR}/${P/_rc/rc}"
-DEPEND="virtual/glibc
- >=media-libs/alsa-lib-0.9.0_rc1
- >=x11-libs/gtk+-1.0.1"
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=media-libs/alsa-lib-0.9.0_rc1
+ >=x11-libs/gtk+-1.0.1"
# This is a list of the tools in the package.
ALSA_TOOLS="ac3dec as10k1 envy24control sb16_csp seq/sbiload"
@@ -21,10 +23,10 @@ src_compile() {
local f
for f in ${ALSA_TOOLS}
do
- cd "${S}/${f}"
- ./configure --host="${CHOST}" --prefix=/usr --mandir=/usr/share/man \
- || die "./configure failed"
- emake || die "Parallel Make Failed"
+ cd "${S}/${f}"
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
done
}
@@ -32,19 +34,19 @@ src_install() {
local f
for f in ${ALSA_TOOLS}
do
- # Install the main stuff
- cd "${S}/${f}"
- make DESTDIR="${D}" install || die
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog COPYING AUTHORS
- do
- if [ -f "${doc}" ]
- then
- mv "${doc}" "${doc}.`basename ${f}`"
- dodoc "${doc}.`basename ${f}`"
- fi
- done
+ # Install the main stuff
+ cd "${S}/${f}"
+ make DESTDIR="${D}" install || die
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog COPYING AUTHORS
+ do
+ if [ -f "${doc}" ]
+ then
+ mv "${doc}" "${doc}.`basename ${f}`"
+ dodoc "${doc}.`basename ${f}`"
+ fi
+ done
done
}
diff --git a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1.ebuild b/media-sound/alsa-tools/alsa-tools-0.9.0_rc1.ebuild
deleted file mode 100644
index b6a10838d73b..000000000000
--- a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.0_rc1.ebuild,v 1.4 2002/07/11 06:30:40 drobbins Exp $
-
-DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="http://www.alsa-project.org"
-
-SRC_URI="ftp://ftp.alsa-project.org/pub/tools/${P/_rc/rc}.tar.bz2"
-S="${WORKDIR}/${P/_rc/rc}"
-
-DEPEND="virtual/glibc
- ~media-libs/alsa-lib-0.9.0_rc1
- >=x11-libs/gtk+-1.0.1"
-
-# This is a list of the tools in the package.
-ALSA_TOOLS="ac3dec as10k1 envy24control sb16_csp seq/sbiload"
-
-src_compile() {
- # Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
- ./configure --host="${CHOST}" --prefix=/usr --mandir=/usr/share/man \
- || die "./configure failed"
- emake || die "Parallel Make Failed"
- done
-}
-
-src_install() {
- local f
- for f in ${ALSA_TOOLS}
- do
- # Install the main stuff
- cd "${S}/${f}"
- make DESTDIR="${D}" install || die
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog COPYING AUTHORS
- do
- if [ -f "${doc}" ]
- then
- mv "${doc}" "${doc}.`basename ${f}`"
- dodoc "${doc}.`basename ${f}`"
- fi
- done
- done
-}
diff --git a/media-sound/alsa-tools/files/digest-alsa-tools-0.9.0_rc1 b/media-sound/alsa-tools/files/digest-alsa-tools-0.9.0_rc1
deleted file mode 100644
index 3071640b689c..000000000000
--- a/media-sound/alsa-tools/files/digest-alsa-tools-0.9.0_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ddec389b7d51d26532904b2080e003eb alsa-tools-0.9.0rc1.tar.bz2 165390