summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-24 23:45:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-24 23:45:35 +0000
commit999d7f5079f207681ae0ceec67fecb41bf0b907d (patch)
tree5256794802d85fde4f93340c689aabfb01108ec1 /media-sound/amsynth/files
parentRemove obsolete version. (diff)
downloadhistorical-999d7f5079f207681ae0ceec67fecb41bf0b907d.tar.gz
historical-999d7f5079f207681ae0ceec67fecb41bf0b907d.tar.bz2
historical-999d7f5079f207681ae0ceec67fecb41bf0b907d.zip
Version bump, bug #170524
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-sound/amsynth/files')
-rw-r--r--media-sound/amsynth/files/amsynth-1.2.0-asneeded.patch45
-rw-r--r--media-sound/amsynth/files/amsynth-1.2.0-cflags.patch26
-rw-r--r--media-sound/amsynth/files/amsynth-1.2.0-debug.patch46
-rw-r--r--media-sound/amsynth/files/digest-amsynth-1.2.03
4 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/amsynth/files/amsynth-1.2.0-asneeded.patch b/media-sound/amsynth/files/amsynth-1.2.0-asneeded.patch
new file mode 100644
index 000000000000..ec1f1bb7e8af
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.2.0-asneeded.patch
@@ -0,0 +1,45 @@
+Index: amSynth-1.2.0/configure.in
+===================================================================
+--- amSynth-1.2.0.orig/configure.in
++++ amSynth-1.2.0/configure.in
+@@ -148,21 +148,25 @@ dnl Set compiler options accordingly
+ dnl
+ dnl
+
++LIBSADDED=""
++
+ if test "$with_oss" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Dwith_oss"
+ fi
+ if test "$with_alsa" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Dwith_alsa"
+- LDFLAGS="$LDFLAGS -lasound"
++ LIBSADDED="$LIBSADDED -lasound"
+ fi
+ if test "$with_jack" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Dwith_jack"
+ fi
+ if test "$with_sndfile" = "yes"; then
+ CXXFLAGS="$CXXFLAGS -Dwith_sndfile"
+- LDFLAGS="$LDFLAGS -lsndfile"
++ LIBSADDED="$LIBSADDED -lsndfile"
+ fi
+
++AC_SUBST(LIBSADDED)
++
+ AC_OUTPUT([
+ Makefile
+ src/Makefile
+Index: amSynth-1.2.0/src/Makefile.am
+===================================================================
+--- amSynth-1.2.0.orig/src/Makefile.am
++++ amSynth-1.2.0/src/Makefile.am
+@@ -16,7 +16,7 @@ amSynth_SOURCES = \
+
+ SUBDIRS = drivers VoiceBoard GUI Effects
+
+-amSynth_LDADD = drivers/libdrivers.a VoiceBoard/libVoiceBoard.a GUI/libGUI.a Effects/libEffects.a
++amSynth_LDADD = drivers/libdrivers.a VoiceBoard/libVoiceBoard.a GUI/libGUI.a Effects/libEffects.a @LIBSADDED@
+
+ amSynth_CFLAGS = $(CFLAGS) -DENABLE_BINRELOC
+ amSynth_CXXFLAGS = $(CXXFLAGS) -DENABLE_BINRELOC
diff --git a/media-sound/amsynth/files/amsynth-1.2.0-cflags.patch b/media-sound/amsynth/files/amsynth-1.2.0-cflags.patch
new file mode 100644
index 000000000000..a2d7e0b8e6a8
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.2.0-cflags.patch
@@ -0,0 +1,26 @@
+Index: amSynth-1.2.0/configure.in
+===================================================================
+--- amSynth-1.2.0.orig/configure.in
++++ amSynth-1.2.0/configure.in
+@@ -5,7 +5,7 @@ AM_CONFIG_HEADER(config.h)
+
+
+ addCXXFLAGS="-D_REENTRANT"
+-CXXFLAGS="-Wall"
++CXXFLAGS="$CXXFLAGS -Wall"
+
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+@@ -117,12 +117,6 @@ else
+ profiling=no
+ fi
+
+-if test $profiling = "no"; then
+- if test $debugging = "no"; then
+- CXXFLAGS="$CXXFLAGS -O3 -ffast-math -fno-exceptions -fomit-frame-pointer"
+- fi
+-fi
+-
+
+ dnl
+ dnl
diff --git a/media-sound/amsynth/files/amsynth-1.2.0-debug.patch b/media-sound/amsynth/files/amsynth-1.2.0-debug.patch
new file mode 100644
index 000000000000..e409fb7a8874
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.2.0-debug.patch
@@ -0,0 +1,46 @@
+Index: amSynth-1.2.0/src/MidiController.cc
+===================================================================
+--- amSynth-1.2.0.orig/src/MidiController.cc
++++ amSynth-1.2.0/src/MidiController.cc
+@@ -5,6 +5,9 @@
+ #include "MidiController.h"
+ #include <fstream>
+ #include <assert.h>
++#ifdef _DEBUG
++#include <iostream>
++#endif
+
+ using namespace std;
+
+Index: amSynth-1.2.0/src/Parameter.cc
+===================================================================
+--- amSynth-1.2.0.orig/src/Parameter.cc
++++ amSynth-1.2.0/src/Parameter.cc
+@@ -71,15 +71,15 @@ Parameter::setValue(float value)
+ controlValue = offset + ::pow( _value, (float)base );
+ #ifdef _DEBUG
+ default:
+- cout << "<Parameter> mode is undefined" << endl;
++ std::cout << "<Parameter> mode is undefined" << std::endl;
+ break;
+ #endif
+ }
+
+ #ifdef _DEBUG
+- cout << "<Parameter::setValue( " << foo
++ std::cout << "<Parameter::setValue( " << foo
+ << " ) min=" << _min << " max=" << _max << " value set to " << _value
+- << " controlValue set to " << controlValue << endl;
++ << " controlValue set to " << controlValue << std::endl;
+ #endif
+
+ // TODO: only update() Listeners it there _was_ a change?
+@@ -88,7 +88,7 @@ Parameter::setValue(float value)
+ for (unsigned i=0; i<updateListeners.size(); i++)
+ {
+ #ifdef _DEBUG
+- cout << "updating UpdateListener " << updateListeners[i] << endl;
++ std::cout << "updating UpdateListener " << updateListeners[i] << std::endl;
+ #endif
+ updateListeners[i]->UpdateParameter (mParamId, controlValue);
+ }
diff --git a/media-sound/amsynth/files/digest-amsynth-1.2.0 b/media-sound/amsynth/files/digest-amsynth-1.2.0
new file mode 100644
index 000000000000..7bc3d2fd4afe
--- /dev/null
+++ b/media-sound/amsynth/files/digest-amsynth-1.2.0
@@ -0,0 +1,3 @@
+MD5 2ba9a0560945c6ac914a15bb243146e2 amSynth-1.2.0.tar.gz 616311
+RMD160 b24b493e1532f3b1ad574856cfaadf8418e32900 amSynth-1.2.0.tar.gz 616311
+SHA256 5fff8dc65bd5550bbf408e3df1123c68e31517bbb7441cbe0b964ab271948b1c amSynth-1.2.0.tar.gz 616311