summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-14 08:52:13 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-14 08:52:13 +0000
commit1150355b6730a1feb71faedb0e3d6b39c3be0951 (patch)
tree4eacd11061224ebe52bc9bf774b49eb589e492e9 /media-sound/audacity
parenttouchups and inherit #15675 (diff)
downloadhistorical-1150355b6730a1feb71faedb0e3d6b39c3be0951.tar.gz
historical-1150355b6730a1feb71faedb0e3d6b39c3be0951.tar.bz2
historical-1150355b6730a1feb71faedb0e3d6b39c3be0951.zip
touchups and inherit #15675
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/audacity-1.1.1-r1.ebuild22
-rw-r--r--media-sound/audacity/audacity-1.1.1.ebuild18
2 files changed, 24 insertions, 16 deletions
diff --git a/media-sound/audacity/audacity-1.1.1-r1.ebuild b/media-sound/audacity/audacity-1.1.1-r1.ebuild
index ecbbbf85dbec..493be4000ac3 100644
--- a/media-sound/audacity/audacity-1.1.1-r1.ebuild
+++ b/media-sound/audacity/audacity-1.1.1-r1.ebuild
@@ -1,22 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.1.1-r1.ebuild,v 1.5 2003/02/13 13:07:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.1.1-r1.ebuild,v 1.6 2003/02/14 08:50:02 vapier Exp $
+
+inherit eutils
-IUSE="oggvorbis"
DESCRIPTION="A free, crossplatform audio editor."
HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}-3.tgz"
+
LICENSE="GPL-2"
+IUSE="oggvorbis"
+SLOT="0"
+KEYWORDS="x86"
+
DEPEND=">=x11-libs/wxGTK-2.2.9
>=app-arch/zip-2.3
>=media-sound/mad-0.14
>=media-libs/id3lib-3.8.0
>=media-libs/libsndfile-1.0.0
oggvorbis? ( >=media-libs/libvorbis-1.0 )"
-SLOT="0"
-KEYWORDS="x86"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}-3.tgz"
+
S="${WORKDIR}/${PN}-src-${PV}-3"
-inherit eutils
src_unpack() {
unpack ${PN}-src-${PV}-3.tgz
@@ -29,7 +33,7 @@ src_compile() {
MAKEOPTS=-j1 emake || die
}
-src_install () {
+src_install() {
make PREFIX="${D}/usr" install || die
dodoc LICENSE.txt README.txt
insinto /etc/skel
@@ -37,8 +41,8 @@ src_install () {
}
pkg_postinst() {
- einfo ""
+ einfo
einfo "If you built Audacity against wxGTK-2.4.0 you must..."
einfo "cp /etc/skel/.Audacity ~"
- einfo ""
+ einfo
}
diff --git a/media-sound/audacity/audacity-1.1.1.ebuild b/media-sound/audacity/audacity-1.1.1.ebuild
index a20822a644c2..c4c965610bed 100644
--- a/media-sound/audacity/audacity-1.1.1.ebuild
+++ b/media-sound/audacity/audacity-1.1.1.ebuild
@@ -1,21 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.1.1.ebuild,v 1.2 2003/02/13 13:08:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.1.1.ebuild,v 1.3 2003/02/14 08:50:02 vapier Exp $
+
+inherit eutils
-IUSE="oggvorbis"
DESCRIPTION="A free, crossplatform audio editor."
HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tgz"
+
LICENSE="GPL-2"
+IUSE="oggvorbis"
+SLOT="0"
+KEYWORDS="x86"
+
DEPEND=">=x11-libs/wxGTK-2.4.0
oggvorbis? ( media-libs/libvorbis )
app-arch/zip
media-sound/mad
media-libs/id3lib"
-SLOT="0"
-KEYWORDS="x86"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tgz"
+
S="${WORKDIR}/${PN}-src-${PV}"
-inherit eutils
src_unpack() {
unpack ${PN}-src-${PV}.tgz
@@ -28,7 +32,7 @@ src_compile() {
MAKEOPTS=-j1 emake || die
}
-src_install () {
+src_install() {
make PREFIX="${D}/usr" install || die
dodoc LICENSE.txt README.txt
}