summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2009-12-12 20:12:45 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2009-12-12 20:12:45 +0000
commitc29c64dd98046c2ddea9402a488f6d970e3558d6 (patch)
tree20968dd1388fcfa6b283c30e80e7e939bb51c960 /media-sound/declick/declick-0.6.5.ebuild
parentVersion bump. (diff)
downloadhistorical-c29c64dd98046c2ddea9402a488f6d970e3558d6.tar.gz
historical-c29c64dd98046c2ddea9402a488f6d970e3558d6.tar.bz2
historical-c29c64dd98046c2ddea9402a488f6d970e3558d6.zip
added am64 keyword, switched to EAPI2, added utf-8 conversion for readme.
Package-Manager: portage-2.2_rc58/cvs/Linux x86_64
Diffstat (limited to 'media-sound/declick/declick-0.6.5.ebuild')
-rw-r--r--media-sound/declick/declick-0.6.5.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-sound/declick/declick-0.6.5.ebuild b/media-sound/declick/declick-0.6.5.ebuild
index 00b5bf0080de..388700ff65ad 100644
--- a/media-sound/declick/declick-0.6.5.ebuild
+++ b/media-sound/declick/declick-0.6.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/declick-0.6.5.ebuild,v 1.4 2009/01/06 22:07:01 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/declick/declick-0.6.5.ebuild,v 1.5 2009/12/12 20:12:45 sbriesen Exp $
+
+EAPI="2"
inherit eutils toolchain-funcs
@@ -10,16 +12,20 @@ SRC_URI="http://home.snafu.de/wahlm/dl8hbs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
DEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# add $LDFLAGS to link command
sed -i -e "s:\(-o declick\):\$(LDFLAGS) \1:g" Makefile
+
+ # convert docs to utf-8
+ if [ -x "$(type -p iconv)" ]; then
+ for X in README; do
+ iconv -f LATIN1 -t UTF8 -o "${X}~" "${X}" && mv -f "${X}~" "${X}" || rm -f "${X}~"
+ done
+ fi
}
src_compile() {