summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-04 20:41:59 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-04 20:41:59 +0000
commitb0731f37e215487afbd7b25c0024aff8f2c69c36 (patch)
treeb41b91ee5975c8990ae43445ae2b0e85de31480b /media-sound/glame
parentkoffice 1.2.1, not yet officially released so masked for now (diff)
downloadhistorical-b0731f37e215487afbd7b25c0024aff8f2c69c36.tar.gz
historical-b0731f37e215487afbd7b25c0024aff8f2c69c36.tar.bz2
historical-b0731f37e215487afbd7b25c0024aff8f2c69c36.zip
Clean up, unmask x86
Diffstat (limited to 'media-sound/glame')
-rw-r--r--media-sound/glame/ChangeLog5
-rw-r--r--media-sound/glame/glame-0.6.4.ebuild19
2 files changed, 15 insertions, 9 deletions
diff --git a/media-sound/glame/ChangeLog b/media-sound/glame/ChangeLog
index fa963e06747b..ce69070c54c2 100644
--- a/media-sound/glame/ChangeLog
+++ b/media-sound/glame/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for media-sound/glame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.6 2002/12/01 01:25:05 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/ChangeLog,v 1.7 2002/12/04 20:41:59 foser Exp $
*glame-0.6.4 (30 Nov 2002)
+ 04 Dec 2002; foser <foser@gentoo.org> glame-0.6.4.ebuild :
+ Fix make issues in a cleaner way
+
30 Nov 2002; foser <foser@gentoo.org> glame-0.6.4.ebuild :
New minor version
diff --git a/media-sound/glame/glame-0.6.4.ebuild b/media-sound/glame/glame-0.6.4.ebuild
index df3837eb8be1..640c5ad98973 100644
--- a/media-sound/glame/glame-0.6.4.ebuild
+++ b/media-sound/glame/glame-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-0.6.4.ebuild,v 1.1 2002/12/01 01:25:05 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/glame/glame-0.6.4.ebuild,v 1.2 2002/12/04 20:41:59 foser Exp $
IUSE="nls gnome"
@@ -11,7 +11,7 @@ HOMEPAGE="http://glame.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="x86"
DEPEND=">=dev-util/guile-1.4-r3
dev-libs/libxml2
@@ -31,9 +31,16 @@ src_unpack() {
mv swapfilegui.c swapfilegui.c.bad
sed -e "s:#include <libintl.h>::" swapfilegui.c.bad > swapfilegui.c
fi
+
+ # fix makefile problem
+ export WANT_AUTOCONF_2_5=1
+ cd ${S}/libltdl
+ autoconf -f
}
src_compile() {
+ local myconf=""
+
if [ "`use gnome`" ]
then
# Use a valid icon for the GNOME menu entry
@@ -43,16 +50,12 @@ src_compile() {
rm src/gui/glame.desktop.old
fi
- local myconf=""
-
use nls && myconf="--enable-nls" \
|| myconf="--disable-nls"
- use gnome || myconf="$myconf --disable-gui"
+ use gnome && myconf="${myconf} --enable-gui" \
+ || myconf="${myconf} --disable-gui"
- # needed to not break configure
- unset CFLAGS
econf --with-included-gettext ${myconf} || die "Configuration failed"
-
emake || die "Compilation failed"
}