summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-05-04 19:25:18 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-05-04 19:25:18 +0000
commitd2f5fc846d5f2d069dd0b2386342b03786a14171 (patch)
tree022e48195f7b947d46c257eec066da71337b0995 /media-sound/id3v2/id3v2-0.1.10.ebuild
parentSwitch to mozilla-launcher since version 1.6 supports thunderbird (diff)
downloadhistorical-d2f5fc846d5f2d069dd0b2386342b03786a14171.tar.gz
historical-d2f5fc846d5f2d069dd0b2386342b03786a14171.tar.bz2
historical-d2f5fc846d5f2d069dd0b2386342b03786a14171.zip
Version bump closes bug #50010.
Diffstat (limited to 'media-sound/id3v2/id3v2-0.1.10.ebuild')
-rw-r--r--media-sound/id3v2/id3v2-0.1.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/id3v2/id3v2-0.1.10.ebuild b/media-sound/id3v2/id3v2-0.1.10.ebuild
new file mode 100644
index 000000000000..fcc15e62de21
--- /dev/null
+++ b/media-sound/id3v2/id3v2-0.1.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3v2/id3v2-0.1.10.ebuild,v 1.1 2004/05/04 19:25:18 eradicator Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="A command line editor for id3v2 tags."
+HOMEPAGE="http://id3v2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/id3v2/${P}.tar.gz"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+
+DEPEND="media-libs/id3lib"
+
+src_unpack()
+{
+ unpack ${A} && cd ${S} || die "unpack failed"
+
+ # The tarball came with a compiled binary. ;^)
+ make clean
+
+ # Use our own CXXFLAGS
+ sed -i -e "/g++/ s|-g|${CXXFLAGS}|" Makefile || die "sed failed"
+
+ # Fix segfault on alpha (and probably other architectures)
+ epatch ${FILESDIR}/${PN}-0.1.9-alpha.patch
+
+ # Fix global functions being declared inline
+ epatch ${FILESDIR}/${P}-noinline.patch
+}
+
+src_compile()
+{
+ emake || die
+}
+
+src_install()
+{
+ dobin id3v2
+ doman id3v2.1
+ dodoc COPYING INSTALL README
+}