summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-11 23:39:08 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-11 23:39:08 +0000
commit47449fc8322663124489c7c38cd1a29f3007c737 (patch)
tree2941cd7227248af4560207fad8bed90409b19c46 /media-sound/lastfmproxy
parentdev-cpp/libgnomemm: Bump to 2.22.0 (upstream version bump, nothing new) (diff)
downloadhistorical-47449fc8322663124489c7c38cd1a29f3007c737.tar.gz
historical-47449fc8322663124489c7c38cd1a29f3007c737.tar.bz2
historical-47449fc8322663124489c7c38cd1a29f3007c737.zip
Initial commit. Fixes bug 131294.
Package-Manager: portage-2.1.5_rc2
Diffstat (limited to 'media-sound/lastfmproxy')
-rw-r--r--media-sound/lastfmproxy/ChangeLog10
-rw-r--r--media-sound/lastfmproxy/Manifest5
-rwxr-xr-xmedia-sound/lastfmproxy/files/lastfmproxy.rc22
-rw-r--r--media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild42
-rw-r--r--media-sound/lastfmproxy/metadata.xml9
5 files changed, 88 insertions, 0 deletions
diff --git a/media-sound/lastfmproxy/ChangeLog b/media-sound/lastfmproxy/ChangeLog
new file mode 100644
index 000000000000..f357d886e8c3
--- /dev/null
+++ b/media-sound/lastfmproxy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/lastfmproxy
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmproxy/ChangeLog,v 1.1 2008/04/11 23:39:07 yngwin Exp $
+
+*lastfmproxy-1.3b (11 Apr 2008)
+
+ 11 Apr 2008; Ben de Groot <yngwin@gentoo.org> +files/lastfmproxy.rc,
+ +metadata.xml, +lastfmproxy-1.3b.ebuild:
+ Initial commit. Ebuild adapted from Daniel Pielmeier and bug 131294.
+
diff --git a/media-sound/lastfmproxy/Manifest b/media-sound/lastfmproxy/Manifest
new file mode 100644
index 000000000000..a373f2a6b0db
--- /dev/null
+++ b/media-sound/lastfmproxy/Manifest
@@ -0,0 +1,5 @@
+AUX lastfmproxy.rc 491 RMD160 0256968525a646ce99273f52a11d120ae80cd46a SHA1 2f5298cdd7f7507c7e2ce8a4a50876010041a56f SHA256 c48564ec68765c12b6284e686582307e79a330617c4c34ec96ea302375606b3a
+DIST lastfmproxy-1.3b.tar.gz 32079 RMD160 d4e4c53a34699eee9ee65402e25fb82a81272505 SHA1 ee6a4ef118d76efefa1dff36c85e48c925ebc4c0 SHA256 b66be0fcc76e557d1306660162db946f97262335f3528cf5d303b3ab3410a881
+EBUILD lastfmproxy-1.3b.ebuild 1338 RMD160 d01511f7bc77d6ec7b8a96ef3679c4a49c137592 SHA1 5b0243d2028e5f7d0f16b3865d97f43c0eaacf4f SHA256 2ec77fb114d5d4ba8cc5bdf79744d860284b611b8dd5c1e32a9c871688273b4b
+MISC ChangeLog 438 RMD160 8af0ce4875c07531c9575b6ca18e9c3844b9f392 SHA1 08c5c6a6020872dbd8d0289b9bf08f0788952caf SHA256 388255ae5b834e5ba3d13bf07ecc8039a4b7734a6be8ec52e9dc6a5b8cce8b9d
+MISC metadata.xml 258 RMD160 c4368de7af5d7e3eab50ac09bb3c0ff1f89b48a5 SHA1 d325a145243dc9f942c9a6eda3b5904530c1b668 SHA256 4fc3e9816ac88894a53efd0217b7b7526a12c717bf1d0a2eda601031566b155b
diff --git a/media-sound/lastfmproxy/files/lastfmproxy.rc b/media-sound/lastfmproxy/files/lastfmproxy.rc
new file mode 100755
index 000000000000..ea19e2e2759b
--- /dev/null
+++ b/media-sound/lastfmproxy/files/lastfmproxy.rc
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start () {
+ ebegin "Starting Last.fm Proxy"
+ start-stop-daemon --start -p /var/run/lastfmproxy.pid -b -m \
+ --exec /usr/share/lastfmproxy/main.py
+ einfo "Stream: http://localhost:1881/lastfm.m3u"
+ einfo "Web frontend: http://localhost:1881/"
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping Last.fm Proxy"
+ start-stop-daemon --stop --quiet -p /var/run/lastfmproxy.pid -m \
+ --exec /usr/share/lastfmproxy/main.py
+ rm -f /var/run/lastfmproxy.pid
+ eend $?
+}
diff --git a/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild b/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild
new file mode 100644
index 000000000000..844f6a0cc85c
--- /dev/null
+++ b/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild,v 1.1 2008/04/11 23:39:07 yngwin Exp $
+
+DESCRIPTION="A proxy server for listening to last.fm streams with any stream-capable audio player"
+HOMEPAGE="http://vidar.gimp.org/lastfmproxy/"
+SRC_URI="http://vidar.gimp.org/wp-content/uploads/2007/12/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ BASE=/usr/share/lastfmproxy
+ cd "${S}"
+ dodoc README.txt ChangeLog.txt
+
+ insinto ${BASE}
+ doins -r *.py data
+ fperms 755 ${BASE}/changestation.py ${BASE}/main.py
+
+ newinitd "${FILESDIR}"/lastfmproxy.rc lastfmproxy
+}
+
+pkg_postinst() {
+ echo
+ einfo "Please modify:"
+ einfo " /usr/share/lastfmproxy/config.py"
+ einfo "with last.fm credentials and/or proxy information."
+ einfo ""
+ einfo "Then, to start lastfmproxy:"
+ einfo " /etc/init.d/lastfmproxy start"
+ einfo ""
+ einfo "Here's how to make the lastfm://station links work:"
+ einfo ' In Firefox, open the location "about:config"'
+ einfo ' Right-click, select "New String"'
+ einfo ' As name, enter "network.protocol-handler.app.lastfm"'
+ einfo ' As value, enter "/usr/share/lastfmproxy/changestation.py"'
+ echo
+}
diff --git a/media-sound/lastfmproxy/metadata.xml b/media-sound/lastfmproxy/metadata.xml
new file mode 100644
index 000000000000..6e9c501620f5
--- /dev/null
+++ b/media-sound/lastfmproxy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>