summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:51:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:51:58 +0000
commitaf6384cb55ebbcf5ee390e0076ffb3f8054a64f0 (patch)
tree767be46ef5a7af2aef5a00b1af11b001392a708a /media-sound/mimd/mimd-0.30.1.ebuild
parentppc stable #271954 (diff)
downloadhistorical-af6384cb55ebbcf5ee390e0076ffb3f8054a64f0.tar.gz
historical-af6384cb55ebbcf5ee390e0076ffb3f8054a64f0.tar.bz2
historical-af6384cb55ebbcf5ee390e0076ffb3f8054a64f0.zip
Fix compile with _FORTIFY_SOURCE=2 wrt #272512, thanks to Diego E. Pettenò.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'media-sound/mimd/mimd-0.30.1.ebuild')
-rw-r--r--media-sound/mimd/mimd-0.30.1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/media-sound/mimd/mimd-0.30.1.ebuild b/media-sound/mimd/mimd-0.30.1.ebuild
index f1e03e5074b4..4bebf27b28e4 100644
--- a/media-sound/mimd/mimd-0.30.1.ebuild
+++ b/media-sound/mimd/mimd-0.30.1.ebuild
@@ -1,37 +1,38 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/mimd-0.30.1.ebuild,v 1.4 2007/01/05 17:34:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mimd/mimd-0.30.1.ebuild,v 1.5 2009/06/06 16:51:58 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="Multicast streaming server for MPEG1/2 and MP3 files."
-
HOMEPAGE="http://darkwing.uoregon.edu/~tkay/mim.html"
SRC_URI="http://darkwing.uoregon.edu/~tkay/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~x86 ~ppc"
IUSE=""
RDEPEND=">=media-plugins/live-2006.12.08
- dev-libs/xerces-c"
+ dev-libs/xerces-c"
DEPEND="${RDEPEND}
dev-lang/perl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}+live-2006.12.08.patch"
- cp Makefile.in Makefile
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+live-2006.12.08.patch \
+ "${FILESDIR}"/${P}-fortify_sources.patch
+ cp -f Makefile.in Makefile
}
+src_configure() { :; }
+
src_compile() {
- emake || die
+ emake || die "emake failed"
}
src_install() {
- dobin mimd
+ dobin mimd || die "dobin failed"
dodoc doc/mimd.pod
if [ -x /usr/bin/pod2html ]; then