summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-11-01 21:41:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-11-01 21:41:54 +0000
commit1c320748c792d235da920e803c87c01d9e73360c (patch)
treefbafaadffa5afe4a21c0b906567ec2b208930b24 /media-sound/pd/pd-0.39_p1.ebuild
parent* latex-package.eclass: (latex-package_src_doinstall): Install pfb files (diff)
downloadhistorical-1c320748c792d235da920e803c87c01d9e73360c.tar.gz
historical-1c320748c792d235da920e803c87c01d9e73360c.tar.bz2
historical-1c320748c792d235da920e803c87c01d9e73360c.zip
Version bumped. Bug 104752.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'media-sound/pd/pd-0.39_p1.ebuild')
-rw-r--r--media-sound/pd/pd-0.39_p1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/pd/pd-0.39_p1.ebuild b/media-sound/pd/pd-0.39_p1.ebuild
new file mode 100644
index 000000000000..8bef1660597e
--- /dev/null
+++ b/media-sound/pd/pd-0.39_p1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.39_p1.ebuild,v 1.1 2005/11/01 21:41:54 matsuu Exp $
+
+IUSE="alsa debug jack"
+
+inherit eutils
+
+# Miller Puckette uses nonstandard versioning scheme that we have to crunch
+MY_P="${P/_p/-}"
+S=${WORKDIR}/${MY_P}/src
+
+DESCRIPTION="real-time music and multimedia environment"
+HOMEPAGE="http://www-crca.ucsd.edu/~msp/software.html"
+SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${MY_P}.src.tar.gz"
+
+LICENSE="|| ( BSD as-is )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )"
+
+src_compile() {
+ local myconf
+
+ # --enable-alsa is bork
+ if ! use alsa; then
+ myconf="${myconf} --disable-alsa"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_enable jack) \
+ $(use_enable debug) \
+ || die "./configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ # tb: install private headers ... several external developers use them
+ insinto /usr/include
+ doins m_imp.h g_canvas.h
+}