summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2004-12-23 20:18:49 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2004-12-23 20:18:49 +0000
commitbc1dc650f9bb3862b8ce680e1d3573127461df86 (patch)
treefa4acdee2ee9da2f6475addc1cb08bc7cb001a3c /media-sound/rezound
parentAdded support for ${ABI} and if it's not set, we do sll ${MULTILIB_ABIS}. Th... (diff)
downloadhistorical-bc1dc650f9bb3862b8ce680e1d3573127461df86.tar.gz
historical-bc1dc650f9bb3862b8ce680e1d3573127461df86.tar.bz2
historical-bc1dc650f9bb3862b8ce680e1d3573127461df86.zip
Fixed a compilation error on ppc.
Diffstat (limited to 'media-sound/rezound')
-rw-r--r--media-sound/rezound/ChangeLog6
-rw-r--r--media-sound/rezound/Manifest17
-rw-r--r--media-sound/rezound/files/undefined-functions.patch38
-rw-r--r--media-sound/rezound/rezound-0.11.1_beta.ebuild6
4 files changed, 52 insertions, 15 deletions
diff --git a/media-sound/rezound/ChangeLog b/media-sound/rezound/ChangeLog
index a09d72d8241d..915912bb09b1 100644
--- a/media-sound/rezound/ChangeLog
+++ b/media-sound/rezound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rezound
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.20 2004/11/17 06:30:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.21 2004/12/23 20:18:49 hansmi Exp $
+
+ 23 Dec 2004; Michael Hanselmann <hansmi@gentoo.org>
+ +files/undefined-functions.patch, rezound-0.11.1_beta.ebuild:
+ Fixed bug #68268, a compilation error on ppc.
*rezound-0.11.1_beta (16 Nov 2004)
diff --git a/media-sound/rezound/Manifest b/media-sound/rezound/Manifest
index fb1f3f9f4edd..950725116e51 100644
--- a/media-sound/rezound/Manifest
+++ b/media-sound/rezound/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 b6b4822e3a4fd630bbaa428cf3e9483d ChangeLog 3447
-MD5 d0d7ea03e238a808414b4426394c100f metadata.xml 221
-MD5 8ab1ed976eb6835e792bbf307c144115 rezound-0.11.1_beta.ebuild 2061
MD5 87686207ef11456860c1c0410311b010 rezound-0.10.0_beta.ebuild 1980
+MD5 d0d7ea03e238a808414b4426394c100f metadata.xml 221
+MD5 1b0bff8575789ccc7fca67e16ba45076 ChangeLog 3610
+MD5 fbad27ad007a7b7925002441020e9950 rezound-0.11.1_beta.ebuild 2218
MD5 e91a09314efa10c88b5ad68c8ced9be7 files/digest-rezound-0.11.1_beta 71
+MD5 3bc1175bcfa6d88bbe86f84556db560c files/undefined-functions.patch 1084
MD5 918c9dd021033e4b01d639be84718c65 files/digest-rezound-0.10.0_beta 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBmvApArHZZzCEUG0RAgioAJ4qcJjx+PdqpTTKrIuY067umwnRdACbBRQg
-PAhphSQvpBzolJ9UkaOPL1A=
-=vuG8
------END PGP SIGNATURE-----
diff --git a/media-sound/rezound/files/undefined-functions.patch b/media-sound/rezound/files/undefined-functions.patch
new file mode 100644
index 000000000000..ef5fbc94e769
--- /dev/null
+++ b/media-sound/rezound/files/undefined-functions.patch
@@ -0,0 +1,38 @@
+--- config/common.h.orig 2004-12-23 20:00:50.710795840 +0100
++++ config/common.h 2004-12-23 20:39:40.271648760 +0100
+@@ -21,6 +21,23 @@
+ #ifndef COMMON_H
+ #define COMMON_H
+
++/* Bugfix for ppc, some functions aren't defined */
++#include <cmath>
++
++#undef MAX
++#define MAX(a,b) ((a) > (b)?(a):(b))
++#undef MIN
++#define MIN(a,b) ((a) < (b)?(a):(b))
++#undef ABS
++#define ABS(a) ((a) >= 0?(a):-(a))
++
++#define floorl(l) floor(l)
++#define nearbyintl(l) nearbyint(l)
++#define fabsl(l) fabs(l)
++#define logl(l) log(l)
++#define expl(l) exp(l)
++#define ceill(l) ceil(l)
++
+ /* common.h -- This file will deal with low-level portability problems. It
+ * should be includede at the top of every package file. */
+
+--- src/frontend_fox/FXWaveCanvas.cpp.orig 2004-12-23 20:18:55.790838600 +0100
++++ src/frontend_fox/FXWaveCanvas.cpp 2004-12-23 20:39:37.568059768 +0100
+@@ -56,6 +56,9 @@
+ #include "../backend/CSoundPlayerChannel.h"
+ #include "drawPortion.h"
+
++#include "../../config/common.h"
++#define max(a,b) MAX(a,b)
++
+ static FXColor playStatusColor=FXRGB(255,0,0);
+
+ #define RIGHT_MARGIN 10
diff --git a/media-sound/rezound/rezound-0.11.1_beta.ebuild b/media-sound/rezound/rezound-0.11.1_beta.ebuild
index c8cf1d12f46a..8515c896ed97 100644
--- a/media-sound/rezound/rezound-0.11.1_beta.ebuild
+++ b/media-sound/rezound/rezound-0.11.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.11.1_beta.ebuild,v 1.1 2004/11/17 06:30:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.11.1_beta.ebuild,v 1.2 2004/12/23 20:18:49 hansmi Exp $
IUSE="alsa oggvorbis jack nls oss portaudio flac soundtouch"
@@ -56,6 +56,10 @@ src_compile() {
myconf="${myconf} `use_enable jack`"
myconf="${myconf} `use_enable portaudio`"
+ # fix compilation errors on ppc, where some
+ # of the required functions aren't defined
+ test "${ARCH}" = ppc && epatch ${FILESDIR}/undefined-functions.patch
+
# following features can't be disabled if already installed:
# -> flac, oggvorbis, soundtouch