summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-09-11 04:07:32 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-09-11 04:07:32 +0000
commit612234db97181eec91f67cfaf1cb6d6381da7597 (patch)
tree1399b2270e2a69cd2d49daa291a8b5b15a6daf88 /media-sound/seq24/seq24-0.8.7.ebuild
parentVersion Bump by Dominique Michel <dominique.michel@citycable.ch> cloes bug #1... (diff)
downloadhistorical-612234db97181eec91f67cfaf1cb6d6381da7597.tar.gz
historical-612234db97181eec91f67cfaf1cb6d6381da7597.tar.bz2
historical-612234db97181eec91f67cfaf1cb6d6381da7597.zip
Version Bump. Closes bug #145352.
Package-Manager: portage-2.1.1
Diffstat (limited to 'media-sound/seq24/seq24-0.8.7.ebuild')
-rw-r--r--media-sound/seq24/seq24-0.8.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/seq24/seq24-0.8.7.ebuild b/media-sound/seq24/seq24-0.8.7.ebuild
new file mode 100644
index 000000000000..95e5c1b86fdb
--- /dev/null
+++ b/media-sound/seq24/seq24-0.8.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7.ebuild,v 1.1 2006/09/11 04:07:32 metalgod Exp $
+
+IUSE="jack lash"
+DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances."
+HOMEPAGE="http://www.filter24.org/seq24/"
+SRC_URI="http://www.filter24.org/seq24/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=media-libs/alsa-lib-0.9.0
+ >=dev-cpp/gtkmm-2.4
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90.0 )
+ lash? ( >=media-sound/lash-0.5.0 )"
+
+src_compile() {
+ econf \
+ $(use_enable jack jack-support) \
+ $(use_enable lash) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README RTC SEQ24
+}