summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-21 13:50:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-21 13:50:35 +0000
commitce51af1c7895b44c18a2535f0fc282260bc84d0f (patch)
tree05ef387526a4f9b732aa4a8d631e77989a1a2f1d /media-sound/soundtracker/soundtracker-0.6.6.ebuild
parentReal networks RealSDK license added (diff)
downloadhistorical-ce51af1c7895b44c18a2535f0fc282260bc84d0f.tar.gz
historical-ce51af1c7895b44c18a2535f0fc282260bc84d0f.tar.bz2
historical-ce51af1c7895b44c18a2535f0fc282260bc84d0f.zip
repoman'd
Diffstat (limited to 'media-sound/soundtracker/soundtracker-0.6.6.ebuild')
-rw-r--r--media-sound/soundtracker/soundtracker-0.6.6.ebuild47
1 files changed, 17 insertions, 30 deletions
diff --git a/media-sound/soundtracker/soundtracker-0.6.6.ebuild b/media-sound/soundtracker/soundtracker-0.6.6.ebuild
index 44f7f9ec3589..4306d1706161 100644
--- a/media-sound/soundtracker/soundtracker-0.6.6.ebuild
+++ b/media-sound/soundtracker/soundtracker-0.6.6.ebuild
@@ -1,61 +1,49 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.6.ebuild,v 1.2 2002/07/11 06:30:41 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.6.ebuild,v 1.3 2002/07/21 13:50:33 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="SoundTracker is a music tracking tool for UNIX/X11 (MOD tracker)"
SRC_URI="http://www.soundtracker.org/dl/v0.6/${P}.tar.gz"
HOMEPAGE="http://www.soundtracker.org"
-DEPEND="=x11-libs/gtk+-1.2*
+DEPEND="sys-libs/zlib
+ =x11-libs/gtk+-1.2*
>=media-libs/audiofile-0.2.1
alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.7 )
- sys-libs/zlib"
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.7 )"
+
RDEPEND="$DEPEND sys-apps/bzip2 sys-apps/gzip app-arch/unzip"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
src_compile() {
local myconf
- if [ -z "`use oss`" ] ; then
- myconf="--disable-oss"
- fi
+ use oss || myconf="--disable-oss"
- if [ -z "`use alsa`" ] ; then
- myconf="${myconf} --disable-alsa"
- fi
+ use esd || myconf="${myconf} --disable-esd"
- if [ -z "`use esd`" ] ; then
- myconf="${myconf} --disable-esd"
- fi
+ use nls || myconf="${myconf} --disable-nls"
- if [ -z "`use gnome`" ] ; then
- myconf="${myconf} --disable-gnome"
- fi
+ use alsa || myconf="${myconf} --disable-alsa"
- if [ -z "`use nls`" ] ; then
- myconf="${myconf} --disable-nls"
- fi
-
- ./configure \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} \
- ${myconf} || die
-
+ use gnome || myconf="${myconf} --disable-gnome"
+ econf ${myconf} || die
emake || die
}
src_install () {
- make \
- prefix=${D}/usr \
+ make \
+ prefix=${D}/usr \
install || die
# strip suid from binary
@@ -67,4 +55,3 @@ src_install () {
dohtml -r doc
}
-