summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-05-24 16:03:10 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-05-24 16:03:10 +0000
commit60508cd4f3cb9560d22d5615ec0c78ffa5d15e5f (patch)
tree018ef2e04b3960e7275cb3a118d949705ca60575 /media-sound
parentGCC3.3 support (diff)
downloadhistorical-60508cd4f3cb9560d22d5615ec0c78ffa5d15e5f.tar.gz
historical-60508cd4f3cb9560d22d5615ec0c78ffa5d15e5f.tar.bz2
historical-60508cd4f3cb9560d22d5615ec0c78ffa5d15e5f.zip
0.9.3c removes /proc/asound/dev directory, to which /dev/snd used to be
a symlink. This doesn't mean much to us, since we use devfs, but the "make install" now may attempt to create real /dev/snd directory, causing a Portage sandbox violation error. This revision fixes this problem (Gentoo bug #21410).
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog11
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.3c-r1.ebuild97
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.3c-r11
3 files changed, 108 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index a55a4a14e29e..5eec137f4b28 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.36 2003/05/20 22:15:33 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.37 2003/05/24 16:03:10 agenkin Exp $
+
+*alsa-driver-0.9.3c-r1 (05 May 2003)
+
+ 05 May 2003; Arcady Genkin <agenkin@gentoo.org> :
+ 0.9.3c removes /proc/asound/dev directory, to which /dev/snd used to be
+ a symlink. This doesn't mean much to us, since we use devfs, but
+ the "make install" now may attempt to create real /dev/snd directory,
+ causing a Portage sandbox violation error. This revision fixes this
+ problem (Gentoo bug #21410).
*alsa-driver-0.9.3c (05 May 2003)
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.3c-r1.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.3c-r1.ebuild
new file mode 100644
index 000000000000..a1af8d31fb1f
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.3c-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.3c-r1.ebuild,v 1.1 2003/05/24 16:03:10 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ make || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+
+ # The "install" target may attempt to create device entries in /dev.
+ # We don't want that to happen, so we bypass it by calling the install-*
+ # targets explicitely.
+ make DESTDIR=${D} \
+ install-modules install-headers install-scripts check-snd-prefix || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3c-r1 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3c-r1
new file mode 100644
index 000000000000..3f77c6bce1e3
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.3c-r1
@@ -0,0 +1 @@
+MD5 340836cc0549b9199b8c7fea4ca62924 alsa-driver-0.9.3c.tar.bz2 1523999