summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-14 09:00:59 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-14 09:00:59 +0000
commit6c537d724f57b3407124b6e0bf5ad344ff670445 (patch)
tree6d0a49124a982c63599e9f1e87394be09fdca9ff /media-sound
parentVersion bump. Closes #19086. (~x86 masked) (diff)
downloadhistorical-6c537d724f57b3407124b6e0bf5ad344ff670445.tar.gz
historical-6c537d724f57b3407124b6e0bf5ad344ff670445.tar.bz2
historical-6c537d724f57b3407124b6e0bf5ad344ff670445.zip
Version bump. Closes #19086. (~x86 masked)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/yammi/Manifest2
-rw-r--r--media-sound/yammi/files/digest-yammi-0.8.11
-rw-r--r--media-sound/yammi/yammi-0.8.1.ebuild78
3 files changed, 80 insertions, 1 deletions
diff --git a/media-sound/yammi/Manifest b/media-sound/yammi/Manifest
index 23e5a41461fd..533fc73fab00 100644
--- a/media-sound/yammi/Manifest
+++ b/media-sound/yammi/Manifest
@@ -1,5 +1,5 @@
MD5 26e30a3921c214ab0f1a041c30372cce yammi-0.7.ebuild 976
-MD5 d9cb05bd57abdfd07017b14b66fcb337 ChangeLog 652
+MD5 333486d9ecb9ed27930a2f9590e95384 ChangeLog 652
MD5 8107430aebee6e6967795a59e9d976c8 yammi-0.8.1.ebuild 2018
MD5 c4e8f80feb349d7c080e877e0d2feb55 files/digest-yammi-0.7 61
MD5 76178822025ac4a204c15642ed7894cd files/digest-yammi-0.8.1 63
diff --git a/media-sound/yammi/files/digest-yammi-0.8.1 b/media-sound/yammi/files/digest-yammi-0.8.1
new file mode 100644
index 000000000000..aac24c8d805c
--- /dev/null
+++ b/media-sound/yammi/files/digest-yammi-0.8.1
@@ -0,0 +1 @@
+MD5 a50c9b93d437d113ce72a182d6a6bc94 yammi-0.8.1.tar.gz 792642
diff --git a/media-sound/yammi/yammi-0.8.1.ebuild b/media-sound/yammi/yammi-0.8.1.ebuild
new file mode 100644
index 000000000000..ed787fb656b5
--- /dev/null
+++ b/media-sound/yammi/yammi-0.8.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header:
+
+IUSE="cdr xmms oggvorbis kde"
+
+inherit flag-o-matic
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="MP3/Ogg/Wav-Manager and Jukebox 4 XMMS/Noatun"
+SRC_URI="mirror://sourceforge/yammi/${P}.tar.gz"
+HOMEPAGE="http://yammi.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/qt-3.1.0-r1
+ >=media-libs/id3lib-3.8.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-sound/lame-3.93.1
+ >=media-sound/mpg123-0.59r-r1
+ >=media-sound/sox-12.17.3-r1
+ cdr? ( >=app-cdr/cdlabelgen-2.4.0
+ >=app-cdr/mp3burn-0.1 )
+ xmms? ( >=media-sound/xmms-1.2.7-r18 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0-r1
+ >=vorbis-tools-1.0-r1 )
+ kde? ( >=kde-base/kde-3.0.4 )"
+
+src_compile() {
+ # need to filter -fomit-frame-pointer for pentium II
+ is-flag "-march=pentium2" && filter-flags "-fomit-frame-pointer"
+
+ local myconf
+ use xmms || myconf="--disable-xmms"
+ use kde || myconf="--disable-noatun ${myconf}"
+
+ if [ -z "`use xmms`" ] && [ -z "`use kde`" ]
+ then
+ myconf="--disable-ogglibs ${myconf}"
+ else
+ use oggvorbis || myconf="--disable-oogvorbis ${myconf}"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=$D install || die
+ dodoc AUTHORS CHANGELOG CREDITS INSTALL README TODO
+}
+
+pkg_postinst() {
+ if [ -z "`use kde`" ] && [ -z "`use xmms`" ]
+ then
+ ewarn "**************************************************************************"
+ ewarn
+ ewarn "Yammi is compiled without support for xmms and noatun."
+ ewarn "Now the functionality of Yammi is very limited."
+ ewarn "It is highly recommended to recompile Yammi."
+ ewarn
+ ewarn "To get xmms support:"
+ ewarn "$ export USE=\"xmms\""
+ ewarn
+ ewarn "To get noatun support:"
+ ewarn "$ export USE=\"kde\""
+ ewarn
+ ewarn "Or to get support for both:"
+ ewarn "$ export USE=\"xmms kde\""
+ ewarn
+ ewarn "**************************************************************************"
+ fi
+}
+