summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-05-31 01:04:34 +0000
committerBen de Groot <yngwin@gentoo.org>2008-05-31 01:04:34 +0000
commit81864e1580c56731296ca0953d63aea27485dd4f (patch)
tree6e0572816798efeca233ed7dcdf0f03d99d9a5e4 /media-sound
parentCommitting build-time fix for bug 214137; SRCDIR was getting passed to the eb... (diff)
downloadhistorical-81864e1580c56731296ca0953d63aea27485dd4f.tar.gz
historical-81864e1580c56731296ca0953d63aea27485dd4f.tar.bz2
historical-81864e1580c56731296ca0953d63aea27485dd4f.zip
Initial import of QtScrobbler - a last.fm committer for portable devices
Package-Manager: portage-2.1.5.2
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qtscrobbler/ChangeLog10
-rw-r--r--media-sound/qtscrobbler/Manifest4
-rw-r--r--media-sound/qtscrobbler/metadata.xml5
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.8.ebuild56
4 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/qtscrobbler/ChangeLog b/media-sound/qtscrobbler/ChangeLog
new file mode 100644
index 000000000000..21885ae7b9f9
--- /dev/null
+++ b/media-sound/qtscrobbler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/qtscrobbler
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/ChangeLog,v 1.1 2008/05/31 01:04:34 yngwin Exp $
+
+*qtscrobbler-0.8 (31 May 2008)
+
+ 31 May 2008; Ben de Groot <yngwin@gentoo.org> +qtscrobbler-0.8.ebuild:
+ Initial import. Ebuild based on the one in ephemeral overlay. Fixes bug
+ 140738.
+
diff --git a/media-sound/qtscrobbler/Manifest b/media-sound/qtscrobbler/Manifest
new file mode 100644
index 000000000000..764d06ad9291
--- /dev/null
+++ b/media-sound/qtscrobbler/Manifest
@@ -0,0 +1,4 @@
+DIST qtscrob-0.8.tar.bz2 126583 RMD160 e37c9bb69943f00375ec51c67b49c5b774fca257 SHA1 9f8305a2775183b063d0bdd6ca8b202c17bb1e12 SHA256 2d52dcff4b50ca5c75ba3c309e087ab80ecf2d6e3f1cd2f5acbcb55c4de915ec
+EBUILD qtscrobbler-0.8.ebuild 1389 RMD160 2953c5e488745788a008c363d872a32d6c992b29 SHA1 31a2cdbb97f1000ca89617c2d3bf60063617956b SHA256 280b6d02b9de7baa6a8b57d786ad4c358252101b12ff9d3dd18da5a1136bbdc2
+MISC ChangeLog 409 RMD160 0348f311e0f293c1dc36d6d2cc7f4479cf0bc2e0 SHA1 0827b579607da47bf05bc5e235014aa410c3ff0d SHA256 ac555018de4987f953aee49a326ab101842aecb4bd48fb03eb1e8c4498654011
+MISC metadata.xml 160 RMD160 10be84fed28405abd22adc6689e87e5bb77e3501 SHA1 0c1bb16a7cc376ef35b87d8699ec9504718d36b9 SHA256 6bafe4a5c7b42309f124ebc2a9d78ebe5379aec4dcdc88c0bda2ab79c9851a6b
diff --git a/media-sound/qtscrobbler/metadata.xml b/media-sound/qtscrobbler/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/qtscrobbler/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild
new file mode 100644
index 000000000000..ae42ff88c918
--- /dev/null
+++ b/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild,v 1.1 2008/05/31 01:04:34 yngwin Exp $
+
+EAPI=1
+inherit eutils qt4
+
+MY_PN="qtscrob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Updates a last.fm profile using information from a supported portable music player"
+HOMEPAGE="http://qtscrob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="qt4"
+
+DEPEND="net-misc/curl
+ qt4? ( || ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 ) )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ # Makefile for cli prog does not read CFLAGS env var.
+ # This sed fixes this.
+ cd "${S}/src/cli"
+ sed -i -e "s:CFLAGS =.*:CFLAGS = \$(INCLUDE) `curl-config --cflags` ${CFLAGS}:" Makefile
+}
+
+
+src_compile() {
+ cd "${S}/src/cli"
+ emake || die "emake qtscrob cli failed"
+ if use qt4; then
+ cd "${S}/src/qt"
+ qmake "${MY_PN}.pro" || die "qmake qtscrob gui failed"
+ emake || die "emake qtscrob gui failed"
+ fi
+}
+
+src_install() {
+ cd "${S}/src/cli"
+ newbin scrobble-cli qtscrobbler-cli
+ if use qt4; then
+ cd "${S}/src/qt"
+ newbin qtscrob qtscrobbler
+ newicon resources/icons/128.png qtscrobbler.png
+ make_desktop_entry qtscrobbler QtScrobbler
+ fi
+ cd "${S}"
+ dodoc AUTHORS CHANGELOG README
+}