summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-23 22:23:50 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-23 22:23:50 +0000
commit88b55834d9c26f28b85fc2c377385620998a44f1 (patch)
tree9f2be84338b017e1ff123487cb77318837e08502 /media-sound
parentVersion bump. (diff)
downloadhistorical-88b55834d9c26f28b85fc2c377385620998a44f1.tar.gz
historical-88b55834d9c26f28b85fc2c377385620998a44f1.tar.bz2
historical-88b55834d9c26f28b85fc2c377385620998a44f1.zip
Initial commit. Ebuild based on the one from upstream.
Package-Manager: portage-2.2_rc9/cvs/Linux 2.6.26.5 i686
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ncmpcpp/ChangeLog10
-rw-r--r--media-sound/ncmpcpp/Manifest4
-rw-r--r--media-sound/ncmpcpp/metadata.xml9
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild44
4 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/ncmpcpp/ChangeLog b/media-sound/ncmpcpp/ChangeLog
new file mode 100644
index 000000000000..d359aecfe5bf
--- /dev/null
+++ b/media-sound/ncmpcpp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/ncmpcpp
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ChangeLog,v 1.1 2008/09/23 22:23:50 yngwin Exp $
+
+*ncmpcpp-0.2.3 (23 Sep 2008)
+
+ 23 Sep 2008; Ben de Groot <yngwin@gentoo.org> +metadata.xml,
+ +ncmpcpp-0.2.3.ebuild:
+ Initial commit. Ebuild based on the one from upstream.
+
diff --git a/media-sound/ncmpcpp/Manifest b/media-sound/ncmpcpp/Manifest
new file mode 100644
index 000000000000..10c94a469b21
--- /dev/null
+++ b/media-sound/ncmpcpp/Manifest
@@ -0,0 +1,4 @@
+DIST ncmpcpp-0.2.3.tar.bz2 300876 RMD160 f79cf3bb42499fdcf0629e0cb4cecbdb8e47b1f5 SHA1 5af088b56c026535cfcb088233f58385537d6215 SHA256 c17c655b90cfb502ad56f1d54a50567d37ff76b196b632f7d480ce20a9a79e0d
+EBUILD ncmpcpp-0.2.3.ebuild 1156 RMD160 dccd4429af20e49d91b24ad3595da104c361bdd7 SHA1 9d134db760fcbe0ab5d81ff34dded55fd7bde9aa SHA256 1dab95401c180d70d918813231ac94d4c429e4eff53d3e204904e9e390b32dfa
+MISC ChangeLog 387 RMD160 6324b1d6b96b10200356324be1ac1edeed42fc1f SHA1 da3a22badbd4122d75690571b8a02d3e8b158d9c SHA256 1c093943a0a07af72802f8e952e65d7a2e91b51f8f2318ac9b409314001f5a91
+MISC metadata.xml 258 RMD160 c4368de7af5d7e3eab50ac09bb3c0ff1f89b48a5 SHA1 d325a145243dc9f942c9a6eda3b5904530c1b668 SHA256 4fc3e9816ac88894a53efd0217b7b7526a12c717bf1d0a2eda601031566b155b
diff --git a/media-sound/ncmpcpp/metadata.xml b/media-sound/ncmpcpp/metadata.xml
new file mode 100644
index 000000000000..6e9c501620f5
--- /dev/null
+++ b/media-sound/ncmpcpp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild
new file mode 100644
index 000000000000..22e0e61b6c22
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild,v 1.1 2008/09/23 22:23:50 yngwin Exp $
+
+inherit eutils
+
+DESCRIPTION="An ncurses mpd client, ncmpc clone with some new features, written in C++"
+HOMEPAGE="http://unkart.ovh.org/ncmpcpp"
+SRC_URI="http://unkart.ovh.org/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+IUSE="curl taglib unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ curl? ( net-misc/curl )
+ taglib? ( media-libs/taglib )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use sys-libs/ncurses unicode && use unicode ; then
+ eerror "Please recompile sys-libs/ncurses with the unicode useflag"
+ die
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode) $(use_with curl) $(use_with taglib) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" docdir="${ROOT}/usr/share/doc/${PF}" \
+ || die "install failed"
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ echo
+}