summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-07-23 00:47:20 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-07-23 00:47:20 +0000
commitc440d50eda8855e617262e02bc8687be09897b75 (patch)
treea811d0f05309bc027027e4fb658b5c02328c2663 /media-sound
parentAdd ~x86-fbsd keyword. (diff)
downloadhistorical-c440d50eda8855e617262e02bc8687be09897b75.tar.gz
historical-c440d50eda8855e617262e02bc8687be09897b75.tar.bz2
historical-c440d50eda8855e617262e02bc8687be09897b75.zip
Version bump, mostly a bugfix release. Adds AltiVec support for WMA thanks to our own lu_zero. Cleaning up old ebuilds.
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog12
-rw-r--r--media-sound/audacious/audacious-1.1.1.ebuild102
-rw-r--r--media-sound/audacious/files/digest-audacious-1.1.16
3 files changed, 119 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 2cdd1b22a4b4..24f3445ee177 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.57 2006/07/15 09:47:27 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.58 2006/07/23 00:47:20 chainsaw Exp $
+
+*audacious-1.1.1 (23 Jul 2006)
+
+ 23 Jul 2006; Tony Vroon <chainsaw@gentoo.org> -files/util-filesize.diff,
+ -audacious-0.2.3.ebuild, -audacious-1.0.0.ebuild,
+ -audacious-1.0.0-r1.ebuild, -audacious-1.1.0_beta1.ebuild,
+ -audacious-1.1.0_beta2.ebuild, -audacious-1.1.0_beta2-r1.ebuild,
+ +audacious-1.1.1.ebuild:
+ Version bump, mostly a bugfix release. Adds AltiVec support for WMA thanks
+ to our own lu_zero. Cleaning up old ebuilds.
15 Jul 2006; Rene Nussbaumer <killerfox@gentoo.org>
audacious-1.1.0.ebuild:
diff --git a/media-sound/audacious/audacious-1.1.1.ebuild b/media-sound/audacious/audacious-1.1.1.ebuild
new file mode 100644
index 000000000000..ed1a9816473a
--- /dev/null
+++ b/media-sound/audacious/audacious-1.1.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.1.1.ebuild,v 1.1 2006/07/23 00:47:20 chainsaw Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aac alsa arts esd flac gnome jack lirc mmx modplug mp3 musepack nls oss sid sndfile timidity vorbis wma"
+
+RDEPEND="app-arch/unzip
+ net-misc/curl
+ media-libs/musicbrainz
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-cpp/libbinio-1.4
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ gnome? ( >=gnome-base/gconf-2.6.0 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-libs/libsamplerate
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-libs/libmpcdec
+ media-libs/taglib )
+ mp3? ( media-libs/taglib )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( media-libs/libsndfile )
+ timidity? ( media-sound/timidity++ )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )"
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ echo
+ ewarn "MP3 support is now optional, you may want to enable the mp3 USE-flag"
+ echo
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ $(use_enable mmx simd) \
+ $(use_enable gnome gconf) \
+ $(use_enable vorbis) \
+ $(use_enable esd) \
+ $(use_enable mp3) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable flac) \
+ $(use_enable aac) \
+ $(use_enable modplug) \
+ $(use_enable lirc) \
+ $(use_enable sndfile) \
+ $(use_enable wma) \
+ $(use_enable sid) \
+ $(use_enable musepack) \
+ $(use_enable jack) \
+ $(use_enable timidity) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ mp3_warning
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.1.1 b/media-sound/audacious/files/digest-audacious-1.1.1
new file mode 100644
index 000000000000..eefccb991588
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.1.1
@@ -0,0 +1,6 @@
+MD5 e9108f71725cf8336f7b965424c285f8 audacious-1.1.1.tgz 3387162
+RMD160 852a2af9ad71fcb9480f32d0581c4864aeaece17 audacious-1.1.1.tgz 3387162
+SHA256 11f0079bfedb01ff7248c32065cca7706d0eba75dd3035a0770ed9c42b94b887 audacious-1.1.1.tgz 3387162
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839