summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-20 14:11:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-20 14:11:41 +0000
commiteb864fa1b863e735a2c09569046f4c6e12fb091d (patch)
treedc2a4e1e3ef93ca6426e22243971c33b3053e4a5 /media-sound
parentforgot to add chm to IUSE from my last commit. (diff)
downloadhistorical-eb864fa1b863e735a2c09569046f4c6e12fb091d.tar.gz
historical-eb864fa1b863e735a2c09569046f4c6e12fb091d.tar.bz2
historical-eb864fa1b863e735a2c09569046f4c6e12fb091d.zip
New nightlie.
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mt-daapd/ChangeLog8
-rw-r--r--media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre12493
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.3.0_pre1249.ebuild143
3 files changed, 153 insertions, 1 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index b3d8216e8981..815e673d5e5f 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.35 2006/06/16 11:54:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.36 2006/06/20 14:11:41 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1249 (20 Jun 2006)
+
+ 20 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -mt-daapd-0.3.0_pre1236.ebuild, +mt-daapd-0.3.0_pre1249.ebuild:
+ New nightlie.
16 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regen manifest.
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1249 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1249
new file mode 100644
index 000000000000..b29ad38446f8
--- /dev/null
+++ b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1249
@@ -0,0 +1,3 @@
+MD5 2db87c0982772968e3c4630d1c59addc mt-daapd-svn-1249.tar.gz 1124181
+RMD160 a47483c7b23ad91832bb030ae492a5d24072bcd8 mt-daapd-svn-1249.tar.gz 1124181
+SHA256 8fe3af5f917b578b9fb871e1ef477942a2be0ace6f403f4f401022fb0f209de0 mt-daapd-svn-1249.tar.gz 1124181
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1249.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1249.ebuild
new file mode 100644
index 000000000000..f74fa82da8e7
--- /dev/null
+++ b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1249.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1249.ebuild,v 1.1 2006/06/20 14:11:41 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+ MY_P="${PN}-svn-${SVN}"
+ SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+ MY_P="${P/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
+
+DEPEND="sys-libs/zlib
+ media-libs/libid3tag
+ !sqlite3? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+ avahi? ( net-dns/avahi ) )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ ffmpeg? ( media-video/ffmpeg )"
+
+pkg_setup() {
+ if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+ eerror "You requested avahi support, but this package requires"
+ eerror "the howl-compat support enabled in net-dns/avahi to work"
+ eerror "with it."
+ eerror
+ eerror "Please recompile net-dns/avahi with +howl-compat."
+ die "Missing howl-compat support in avahi."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ local howlincludes
+
+ append-flags -fno-strict-aliasing
+
+ # howl support?
+ if use howl; then
+ use avahi && \
+ howlincludes="/usr/include/avahi-compat-howl" || \
+ howlincludes="/usr/include/howl"
+
+ myconf="${myconf}
+ --enable-howl
+ --with-howl-libs=/usr/$(get_libdir)
+ --with-howl-includes=${howlincludes}"
+ fi
+
+ # Bug 65723
+ if use vorbis; then
+ myconf="${myconf} --enable-oggvorbis"
+ fi
+
+ econf \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable flac) \
+ $(use_enable !sqlite3 sqlite) \
+ $(use_enable sqlite3) \
+ $(use_enable ffmpeg) \
+ --with-ffmpeg-includes=${ROOT}/usr/include/ffmpeg \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+ cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+ if ! use howl; then
+ sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+ elif ! use avahi; then
+ sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+ else
+ sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto /etc
+ newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+ doins contrib/mt-daapd.playlist
+
+ newinitd ${WORKDIR}/initd ${PN}
+
+ keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You have to configure your mt-daapd.conf following"
+ einfo "/etc/mt-daapd.conf.example file."
+ einfo
+
+ if use howl; then
+ use avahi && \
+ howlservice="avahi-daemon" || \
+ howlservice="mDNSResponder"
+
+ einfo
+ einfo "Since you want to use howl instead of the internal mdnsd"
+ einfo "you need to make sure that you have ${howlservice} configured"
+ einfo "and running to use mt-daapd."
+ einfo
+
+ if use avahi; then
+ einfo "Avahi support is currently experimental, it does not work"
+ einfo "as intended when using more than one mt-daapd instance."
+ einfo "If you want to run more than one mt-daapd, just use the"
+ einfo "internal mdnsd by building with -howl flag."
+ fi
+ fi
+
+ if use vorbis; then
+ einfo
+ einfo "You need to edit you extensions list in /etc/mt-daapd.conf"
+ einfo "if you want your mt-daapd to serve ogg files."
+ einfo
+ fi
+
+ einfo
+ einfo "If you want to start more than one ${PN} service, symlink"
+ einfo "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+ einfo "load the data from /etc/${PN}.d/<name>.conf."
+ einfo "Make sure that you have different cache directories for them."
+ einfo
+}