summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-02 17:58:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-02 17:58:54 +0000
commit699a95305d26a06ff5751a3e9ab4f48f03b7e8df (patch)
tree95d071e5b56ef9dc719ffcab9ca2608ee4fbc69d /media-tv/mythfrontend
parentAdded a patch to solve compilation issues on 2.6 headers, closes bug #39276. (diff)
downloadhistorical-699a95305d26a06ff5751a3e9ab4f48f03b7e8df.tar.gz
historical-699a95305d26a06ff5751a3e9ab4f48f03b7e8df.tar.bz2
historical-699a95305d26a06ff5751a3e9ab4f48f03b7e8df.zip
Version bump
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog7
-rw-r--r--media-tv/mythfrontend/Manifest2
-rw-r--r--media-tv/mythfrontend/files/digest-mythfrontend-0.141
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.14.ebuild100
4 files changed, 109 insertions, 1 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index 30db90df8ea4..80766c29f610 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.9 2004/01/15 18:03:50 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.10 2004/02/02 17:58:54 aliz Exp $
+
+*mythfrontend-0.14 (02 Feb 2004)
+
+ 02 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythfrontend-0.14.ebuild:
+ Version bump
15 Jan 2004; Max Kalika <max@gentoo.org> mythfrontend-0.13.ebuild:
Bump to stable x86.
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index 27ad1ecb1408..597495dbe11c 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -1,3 +1,4 @@
+MD5 663f4e7bbfc6baab4c2dafc872bec3e2 mythfrontend-0.14.ebuild 2809
MD5 ce0bdac63542c75b7f5d0135723372a8 mythfrontend-0.11.ebuild 1415
MD5 91b0c4e7dd348f57e5c3ef83054059a2 mythfrontend-0.13.ebuild 2808
MD5 5dff04c95dbb19d6712eeee47a55df48 mythfrontend-0.10.ebuild 1479
@@ -8,3 +9,4 @@ MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythfrontend-0.10 65
MD5 5234ae53ed7b1bb9ed541d47207430f8 files/digest-mythfrontend-0.11 65
MD5 8919549e83320ae499758823c2488901 files/digest-mythfrontend-0.12 65
MD5 a01439b4ddf480862e31867fc4689698 files/digest-mythfrontend-0.13 65
+MD5 24ab1e90e64fb0be4704e74b633e96b1 files/digest-mythfrontend-0.14 65
diff --git a/media-tv/mythfrontend/files/digest-mythfrontend-0.14 b/media-tv/mythfrontend/files/digest-mythfrontend-0.14
new file mode 100644
index 000000000000..0d9553b02a81
--- /dev/null
+++ b/media-tv/mythfrontend/files/digest-mythfrontend-0.14
@@ -0,0 +1 @@
+MD5 c2ea3e39580d70aaa22c36a35f6afcca mythtv-0.14.tar.bz2 5802666
diff --git a/media-tv/mythfrontend/mythfrontend-0.14.ebuild b/media-tv/mythfrontend/mythfrontend-0.14.ebuild
new file mode 100644
index 000000000000..1dbfb6006167
--- /dev/null
+++ b/media-tv/mythfrontend/mythfrontend-0.14.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.14.ebuild,v 1.1 2004/02/02 17:58:54 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project frontend."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+
+RDEPEND="${DEPEND}
+ !media-tv/mythtv"
+
+S="${WORKDIR}/mythtv-${PV}"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "mythtv.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ rm -rf "${D}"/usr/bin/myth{backend,commflag,filldatabase,transcode} \
+ "${D}/usr/share/mythtv/setup.xml"
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+}