summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-06-28 16:21:19 +0000
committerDaniel Goller <morfic@gentoo.org>2004-06-28 16:21:19 +0000
commit8396589f4d9d0461fd791de0477db16f7774255e (patch)
treea4429c6852d6854b3c158716bbb7337f747eb431 /media-tv
parentversion bump and gcc-3.4 patch, #53638 (diff)
downloadhistorical-8396589f4d9d0461fd791de0477db16f7774255e.tar.gz
historical-8396589f4d9d0461fd791de0477db16f7774255e.tar.bz2
historical-8396589f4d9d0461fd791de0477db16f7774255e.zip
Added patch to allow compilation with gcc-3.4 closing bug 52819
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/Manifest5
-rw-r--r--media-tv/mythtv/files/gcc-3.4-fix.patch39
-rw-r--r--media-tv/mythtv/mythtv-0.15.1.ebuild11
4 files changed, 57 insertions, 5 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 6a343cd73a94..d466962433d2 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.24 2004/06/25 00:32:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.25 2004/06/28 16:21:19 morfic Exp $
+
+ 28 Jun 2004; Daniel Goller <morfic@gentoo.org> mythtv-0.15.1.ebuild:
+ Added patch to allow compilation on gcc-3.4.0 conditionally
+ Patch thanks to Herbie Hopkins
+ Closes bug #52819
07 Jun 2004; Aron Griffis <agriffis@gentoo.org> mythtv-0.13-r1.ebuild,
mythtv-0.14-r1.ebuild, mythtv-0.15.1.ebuild:
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 9c10582cd0d8..04bcc64affa0 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,7 +1,7 @@
-MD5 dda8b149a7c0dac772214e99419727ad mythtv-0.15.1.ebuild 6465
+MD5 3d9bee3ecb9fb56ee0662360121d9792 mythtv-0.15.1.ebuild 6637
MD5 bb8f641b460d061161d9982b0464b9dc mythtv-0.13-r1.ebuild 4519
MD5 069bb2ed03255dd27030c717e89ff508 mythtv-0.14-r1.ebuild 5581
-MD5 d05e5651c81776d156b494e26d46c14e ChangeLog 5675
+MD5 288559b6d725c05b02052762df93c564 ChangeLog 5860
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 75594236f281302bcb8f60629e0da65b files/tvformat.fix.0.13.diff 407
MD5 788cdcff1808794391bf5ef2e157b5fb files/digest-mythtv-0.15.1 67
@@ -10,4 +10,5 @@ MD5 24ab1e90e64fb0be4704e74b633e96b1 files/digest-mythtv-0.14-r1 65
MD5 3c150f80fdec582108af25558f4a5716 files/mythbackend.conf 862
MD5 f34c79d00b235a08f18cf9f2107d6390 files/mythtv-0.15-directfb.patch 1185
MD5 7eb7585f7d3619b53ce2ca1180093f82 files/mythbackend.rc6 1660
+MD5 e7cc68f54ad1c6128aec944e105189e3 files/gcc-3.4-fix.patch 1773
MD5 b3a4780890d53640604812b8069a8297 files/mythfilldatabase.cron 74
diff --git a/media-tv/mythtv/files/gcc-3.4-fix.patch b/media-tv/mythtv/files/gcc-3.4-fix.patch
new file mode 100644
index 000000000000..097177687318
--- /dev/null
+++ b/media-tv/mythtv/files/gcc-3.4-fix.patch
@@ -0,0 +1,39 @@
+diff -ur mythtv-0.15.1.orig/libs/libmythtv/fifowriter.cpp mythtv-0.15.1/libs/libmythtv/fifowriter.cpp
+--- mythtv-0.15.1.orig/libs/libmythtv/fifowriter.cpp 2004-06-02 21:06:54.427866608 +0100
++++ mythtv-0.15.1/libs/libmythtv/fifowriter.cpp 2004-06-02 21:08:37.942130048 +0100
+@@ -21,9 +21,9 @@
+ maxblksize = new long[count];
+ killwr = new int[count];
+ fbcount = new int[count];
+- fifo_buf = new (struct fifo_buf *)[count];
+- fb_inptr = new (struct fifo_buf *)[count];
+- fb_outptr = new (struct fifo_buf *)[count];
++ fifo_buf = new fifo_ptr[count];
++ fb_inptr = new fifo_ptr[count];
++ fb_outptr = new fifo_ptr[count];
+ fifothrds = new pthread_t[count];
+ fifo_lock = new pthread_mutex_t [count];
+ empty_cond = new pthread_cond_t[count];
+diff -ur mythtv-0.15.1.orig/libs/libmythtv/fifowriter.h mythtv-0.15.1/libs/libmythtv/fifowriter.h
+--- mythtv-0.15.1.orig/libs/libmythtv/fifowriter.h 2004-06-02 21:06:54.423867216 +0100
++++ mythtv-0.15.1/libs/libmythtv/fifowriter.h 2004-06-02 21:08:03.708334376 +0100
+@@ -29,6 +29,7 @@
+ long blksize;
+ } **fifo_buf, **fb_inptr, **fb_outptr;
+
++ typedef struct fifo_buf* fifo_ptr;
+ pthread_t *fifothrds;
+ pthread_mutex_t *fifo_lock;
+ pthread_cond_t *full_cond, *empty_cond;
+diff -ur mythtv-0.15.1.orig/settings.pro mythtv-0.15.1/settings.pro
+--- mythtv-0.15.1.orig/settings.pro 2004-06-02 21:06:54.474859464 +0100
++++ mythtv-0.15.1/settings.pro 2004-06-02 21:07:07.013953232 +0100
+@@ -14,7 +14,7 @@
+
+ release {
+ DEFINES += MMX
+- QMAKE_CXXFLAGS_RELEASE = -O3 -march=pentiumpro -fomit-frame-pointer
++ QMAKE_CXXFLAGS_RELEASE = -O3 -march=pentiumpro -fomit-frame-pointer -fpermissive
+ QMAKE_CFLAGS_RELEASE = $${QMAKE_CXXFLAGS_RELEASE}
+ }
+
diff --git a/media-tv/mythtv/mythtv-0.15.1.ebuild b/media-tv/mythtv/mythtv-0.15.1.ebuild
index 1e8372bf94ba..3585cd529bac 100644
--- a/media-tv/mythtv/mythtv-0.15.1.ebuild
+++ b/media-tv/mythtv/mythtv-0.15.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.4 2004/06/25 00:32:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.5 2004/06/28 16:21:19 morfic Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils gcc
DESCRIPTION="Homebrew PVR project."
HOMEPAGE="http://www.mythtv.org/"
@@ -61,6 +61,13 @@ src_unpack() {
done
use directfb && epatch ${FILESDIR}/mythtv-0.15-directfb.patch
+
+ #Applies patch for gcc-3.4.0 closing bug #52819
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/gcc-3.4-fix.patch
+ fi
+
}
src_compile() {