summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-27 07:50:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-27 07:50:09 +0000
commit0d6fd809c16b0a76ce2e053bc209e0f1a831dbf7 (patch)
tree4fa8cc7c71c5000122ad1996501b0267784f1e7e /media-video/ffmpeg/ffmpeg-9999.ebuild
parentAdd alsa/oss/3dnow useflags and disable servertest as its mainly broken (diff)
downloadhistorical-0d6fd809c16b0a76ce2e053bc209e0f1a831dbf7.tar.gz
historical-0d6fd809c16b0a76ce2e053bc209e0f1a831dbf7.tar.bz2
historical-0d6fd809c16b0a76ce2e053bc209e0f1a831dbf7.zip
no need for local variables when we use them only once
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f505b64e13fb..2272eda371b0 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.7 2009/01/27 07:41:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.8 2009/01/27 07:50:09 aballier Exp $
ESVN_REPO_URI="svn://svn.mplayerhq.hu/ffmpeg/trunk"
@@ -129,10 +129,7 @@ src_compile() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- local mymarch=$(get-flag march)
- local mymcpu=$(get-flag mcpu)
- local mymtune=$(get-flag mtune)
- for i in $mymarch $mymcpu $mymtune ; do
+ for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
myconf="${myconf} --cpu=$i"
break
done