summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-10-25 11:19:29 +0000
committerSimon Stelling <blubb@gentoo.org>2006-10-25 11:19:29 +0000
commitb3629e90420da5c102c829e4ea2b21db4cd53be0 (patch)
treec94debbf12578f25ea54d72ac67cbdec351f554f /media-video/mplayer/mplayer-1.0_pre8-r1.ebuild
parentAdded <dev-lang/mono-1.1.17 dependency to dev-dotnet/xsp-1.1.10-r1.ebuild (diff)
downloadhistorical-b3629e90420da5c102c829e4ea2b21db4cd53be0.tar.gz
historical-b3629e90420da5c102c829e4ea2b21db4cd53be0.tar.bz2
historical-b3629e90420da5c102c829e4ea2b21db4cd53be0.zip
backport the asm fixes and don't hard-enable mmxext either
Package-Manager: portage-2.1.2_pre3-r2
Diffstat (limited to 'media-video/mplayer/mplayer-1.0_pre8-r1.ebuild')
-rw-r--r--media-video/mplayer/mplayer-1.0_pre8-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild b/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild
index 46e5786d9100..b5fc16cd2a56 100644
--- a/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild,v 1.12 2006/10/06 12:43:24 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre8-r1.ebuild,v 1.13 2006/10/25 11:19:29 blubb Exp $
inherit eutils flag-o-matic
@@ -354,19 +354,19 @@ src_compile() {
# Advanced Options #
#################
# Platform specific flags, hardcoded on amd64 (see below)
- use x86 && myconf="${myconf} $(use_enable 3dnow)"
- use x86 && myconf="${myconf} $(use_enable 3dnowext)";
+ myconf="${myconf} $(use_enable 3dnow)"
+ myconf="${myconf} $(use_enable 3dnowext)";
use x86 && myconf="${myconf} $(use_enable sse)"
use x86 && myconf="${myconf} $(use_enable sse2)"
use x86 && myconf="${myconf} $(use_enable mmx)"
- use x86 && myconf="${myconf} $(use_enable mmxext)"
+ myconf="${myconf} $(use_enable mmxext)"
use debug && myconf="${myconf} --enable-debug=3"
# mplayer now contains SIMD assembler code for amd64
# AMD64 Team decided to hardenable SIMD assembler for all users
# Danny van Dyk <kugelfang@gentoo.org> 2005/01/11
if use amd64; then
- myconf="${myconf} --enable-3dnow --enable-3dnowext --enable-sse --enable-sse2 --enable-mmx --enable-mmxext"
+ myconf="${myconf} --enable-sse --enable-sse2 --enable-mmx"
fi
if use ppc64