summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-25 20:57:59 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-25 20:57:59 +0000
commit233b07237774bb15dfeafc1f7859e5dd7859619c (patch)
tree32cd33fe7ca32fd251ff8bb80bac0d7e38628604 /media-video
parentStable on amd64 too, works just fine. (diff)
downloadhistorical-233b07237774bb15dfeafc1f7859e5dd7859619c.tar.gz
historical-233b07237774bb15dfeafc1f7859e5dd7859619c.tar.bz2
historical-233b07237774bb15dfeafc1f7859e5dd7859619c.zip
Bump to EAPI 4.
Package-Manager: portage-2.2.0_alpha122/cvs/Linux x86_64
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitlecomposer/ChangeLog11
-rw-r--r--media-video/subtitlecomposer/subtitlecomposer-0.5.3-r1.ebuild54
2 files changed, 62 insertions, 3 deletions
diff --git a/media-video/subtitlecomposer/ChangeLog b/media-video/subtitlecomposer/ChangeLog
index 97d70c06456d..671550eb0573 100644
--- a/media-video/subtitlecomposer/ChangeLog
+++ b/media-video/subtitlecomposer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/subtitlecomposer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.9 2011/07/01 20:29:57 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.10 2012/08/25 20:57:59 creffett Exp $
+
+*subtitlecomposer-0.5.3-r1 (25 Aug 2012)
+
+ 25 Aug 2012; Chris Reffett <creffett@gentoo.org>
+ +subtitlecomposer-0.5.3-r1.ebuild:
+ Bump to EAPI 4.
01 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
files/subtitlecomposer-linkage-patch.patch:
@@ -46,4 +52,3 @@
+subtitlecomposer-0.4.1.ebuild:
Initial import. Thanks to the various people in bug 202503 for reporting,
submitting and improving the ebuild.
-
diff --git a/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r1.ebuild b/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..8a5c7d563254
--- /dev/null
+++ b/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/subtitlecomposer-0.5.3-r1.ebuild,v 1.1 2012/08/25 20:57:59 creffett Exp $
+
+EAPI=4
+
+KDE_LINGUAS="bg cs de el es fr pl pt_BR sr"
+inherit kde4-base
+
+DESCRIPTION="Text-based subtitles editor."
+HOMEPAGE="http://www.sourceforge.net/projects/subcomposer/"
+SRC_URI="mirror://sourceforge/subcomposer/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug gstreamer xine"
+
+RDEPEND="
+ gstreamer? ( media-libs/gstreamer )
+ xine? ( media-libs/xine-lib )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # linkage issue
+ epatch "${FILESDIR}/${PN}-linkage-patch.patch"
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+
+ sed -e '/ADD_SUBDIRECTORY( api )/s/^/# DISABLED/' \
+ -i src/main/scripting/examples/CMakeLists.txt \
+ || die "failed to disable installation of scripting API"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gstreamer GStreamer)
+ $(cmake-utils_use_with xine)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ echo
+ elog "Some example scripts provided by ${PV} require dev-lang/ruby"
+ elog "or dev-lang/python to be installed."
+ echo
+}