summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-02-05 21:35:07 +0000
committerBryan Stine <battousai@gentoo.org>2004-02-05 21:35:07 +0000
commit755e9a733714025c93a2492cfb832db5ae4d2823 (patch)
tree3629af73fa795b088b1c1a38623bd36ae509c247 /media-video
parentupdate audiofile & buddy deps (diff)
downloadhistorical-755e9a733714025c93a2492cfb832db5ae4d2823.tar.gz
historical-755e9a733714025c93a2492cfb832db5ae4d2823.tar.bz2
historical-755e9a733714025c93a2492cfb832db5ae4d2823.zip
Fix globbing in xfree sdk USE detection.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ati-gatos/ChangeLog9
-rw-r--r--media-video/ati-gatos/Manifest6
-rw-r--r--media-video/ati-gatos/ati-gatos-4.3.0.ebuild4
3 files changed, 12 insertions, 7 deletions
diff --git a/media-video/ati-gatos/ChangeLog b/media-video/ati-gatos/ChangeLog
index 6af7e9128745..8e95ef18b26b 100644
--- a/media-video/ati-gatos/ChangeLog
+++ b/media-video/ati-gatos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ati-gatos
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.9 2004/01/15 06:20:29 battousai Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.10 2004/02/05 21:35:07 battousai Exp $
+
+ 05 Feb 2004; Bryan Stine <battousai@gentoo.org>; :
+ Fix globbing in xfree sdk USE detection. If sdk was in USE when emerging
+ xfree-drm, this would catch that and accept it, which would allow it to
+ install without an actual SDK present.
*ati-gatos-4.3.0 (13 Jan 2004)
diff --git a/media-video/ati-gatos/Manifest b/media-video/ati-gatos/Manifest
index 04154b11abfd..f3d9bff8af93 100644
--- a/media-video/ati-gatos/Manifest
+++ b/media-video/ati-gatos/Manifest
@@ -1,4 +1,4 @@
-MD5 909c81fb5d11eb05efdf420d56460f57 files/digest-ati-gatos-4.3.0 68
-MD5 482fbfa8c6df0649efa707912ad740ad ati-gatos-4.3.0.ebuild 2168
-MD5 ad105de6576d32e98e5925d31c484465 ChangeLog 1476
+MD5 b789d37b86955703f19ce9076856cf36 ati-gatos-4.3.0.ebuild 2174
+MD5 42be4991c3849473ab12ae757c9a5f99 ChangeLog 1721
MD5 4def5ade0c1b7eb5afaf3ba72860cdfd metadata.xml 339
+MD5 909c81fb5d11eb05efdf420d56460f57 files/digest-ati-gatos-4.3.0 68
diff --git a/media-video/ati-gatos/ati-gatos-4.3.0.ebuild b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
index 70bce22bf759..afc0a59102e5 100644
--- a/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
+++ b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.3.0.ebuild,v 1.4 2004/01/15 06:20:29 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.3.0.ebuild,v 1.5 2004/02/05 21:35:07 battousai Exp $
inherit eutils
@@ -18,7 +18,7 @@ DEPEND="${DEPEND}
x11-base/xfree"
pkg_setup() {
- if [ ! "`grep gatos /var/db/pkg/x11-base/xfree*/USE`" ]
+ if [ ! "`grep gatos /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
then
ewarn "This package requires that xfree was merged with the gatos USE flag enabled."
die "Please merge xfree with the gatos and sdk USE flags enabled."